Jump to content

ISY Program Will not Run


sanders2222

Recommended Posts

I am experiencing strange program behavior. My irrigation program will not run this evening, even though the program conditions are true (on console). The program is pretty straightforward and has been running correctly this summer. But this evening I can’t force it to run manually.

 If
       $iDayofYear >= $iWB_NextIrrigateDay

Then
       Run Program 'Z1 Lake Lawn' (Then Path)
       Wait  12 minutes 
       Run Program 'Z1 Lake Lawn' (Else Path)
       Wait  15 seconds
       Run Program 'Z2 Deck Lawn' (Then Path)
       Wait  12 minutes 
       Run Program 'Z2 Deck Lawn' (Else Path)
       Wait  15 seconds
       Run Program 'Z5 Side Lawn' (Then Path)
       Wait  8 minutes 
       Run Program 'Z5 Side Lawn' (Else Path)
       Wait  5 seconds
       Run Program 'Z7 Street Lawn' (Then Path)
       Wait  8 minutes 
       Run Program 'Z7 Street Lawn' (Else Path)
       Wait  10 seconds
       Run Program 'Water Shrubs' (If)

Else
       Irrigation - Cycle Complete

I wonder if I need to reboot my ISY for some reason. Other programs are also not running. Some lighting scenes also are not on (that should be). It’s almost like I'm having communication errors, or a PLM that may be dying. Except when I try to run this program, nothing happens. The ISY will not report the program status as running (due to the wait actions). So wouldn’t that be an ISY problem and not something else?

 

Update: In the morning I rebooted my ISY and that solved the problem with the program.

I looked at the error log and if my sprinklers worked the morning of 8/3, I don't see anything that would indicate a reason the programs were frozen in the evening.

Wed 2012/08/01 04:31:36 PM	System	-100	[DHCP] state=RENEW	
Thu 2012/08/02 04:31:35 AM	System	-100	[DHCP] state=RENEW	
Thu 2012/08/02 07:47:01 AM	System	-5012	132	
Thu 2012/08/02 04:31:44 PM	System	-100	[DHCP] state=RENEW	
Thu 2012/08/02 07:02:38 PM	System	-140005	CLI-WBug	
Thu 2012/08/02 08:16:56 PM	System	-10011	n/a	
Fri 2012/08/03 11:20:37 AM	System	-140000	datafeed.weatherbug.com	
Fri 2012/08/03 01:31:46 PM	System	-100	[DHCP] state=RENEW	
Fri 2012/08/03 01:44:37 PM	System	-140000	datafeed.weatherbug.com	
Fri 2012/08/03 05:00:23 PM	System	-60001	pool.ntp.org	
Fri 2012/08/03 05:00:31 PM	System	-60001	pool.ntp.org	
Fri 2012/08/03 09:44:27 PM	System	-5012	138	
Fri 2012/08/03 11:13:41 PM	System	-5012	139	
Sat 2012/08/04 07:56:22 AM	System	-170001	UDQ:Queue Full: IPOLLWAKEUP	
Sat 2012/08/04 07:56:23 AM	System	-170001	UDQ:Queue Full: ELK	
Sat 2012/08/04 07:56:24 AM	System	-170001	UDQ: Queue(s) Full, message ignored	
Sat 2012/08/04 07:56:10 AM	System	-5	Start	

Link to comment

Hello sanders2222,

 

This is quite odd. So, in short, the program stated the status to be true but the last runtime was not updated and the program did not run?

 

And, you could not run any other program? If this is the case, then, could you actually turn on/off any other devices? If you look at your regular log, do you see any -2s?

 

With kind regards,

Michel

Link to comment

Thanks for looking at this Michel and your interest in making a great system even better!

So, in short, the program stated the status to be true but the last runtime was not updated and the program did not run?
This is correct.
And' date=' you could not run any other program? [/quote']Well, it seemed like most programs would not work. Maybe the programs that used a 'Wait' action would not go. I found I could run my sprinkler 'control & monitor' programs (no 'Wait' in these, nor any condition test).

Program Z2 Deck Lawn

If
  - No Conditions - (To add one, press 'Schedule' or 'Condition')
Then
       Set 'Outdoors / _Irrigation / Z2 Deck Lawn 01.DD.AF.2' On
       $iIrr_Zone_Running  = 2
Else
       Set 'Outdoors / _Irrigation / Z2 Deck Lawn 01.DD.AF.2' Off
       $iIrr_Zone_Running  = 0

I noticed I could run the 'Then' & else clauses, starting/stopping the zone as well as update the device status and variable value.

If this is the case, then, could you actually turn on/off any other devices?
Yes. It appeared I could control my the devices from the console.
If you look at your regular log, do you see any -2s?
Not sure what you are referring to "-2s". An excerpt of my log (see attached) shows the irrigation program ran in the morning (8-03 6:20am) but not in the evening (7:56pm). Instead, you see attempts (by me) to control watering wiith my android phone.

One interesting thing I noticed is a number of commands involving my thermostat. This behavior continued until I rebooted the ISY (8-04 @ 7:56am). Another obsevation of my log shows when I was able to run the irrigation program mannually (8-04 8:10am, after reboot). It also appears a number of redundant commands are being processed by the ISY. I hope you can make something of this log excerpt or explain whatever my issues were. But since the reboot, things are now running normally.

Link to comment

Archived

This topic is now archived and is closed to further replies.


  • Recently Browsing

    • No registered users viewing this page.
  • Forum Statistics

    • Total Topics
      36.6k
    • Total Posts
      368k
×
×
  • Create New...