Jump to content

Best way to recover from "unable to read xxx.rec" file?


Recommended Posts



I use and enjoy my ISY 99i pro every day. I also appreciate both the great support from ISY and forum members.


My system has worked fine until, today I had a problem backing it up with the "unable to read xxx.rec" file problem. I am looking for the best way forward.


Running 4.1.0. Everything working OK. Had a few thunderstorms/loss of power in the last week but everything seemed to resume OK. I have a fairly recent ISY backup.


Today I added a new Insteon dualband outdoorlinc. When I added the device (add and with delete links), ISY complained about not being able to read something (can't remember what). However, the device seemed added OK and I can turn it on and off via ISY.


Here comes the problem. Then I tried to back up my ISY. It starts but then gets to 1ABF5D.REC and hangs. Finally complains can't read the .REC file and stops the backup.


1ABF5D is my 220V linc for controlling my hot water heater. I tried and can turn on and off the 1ABF5D via ISY. However, when I try to query to "show device link table" or "show ISY link table" both fail with unable to read /CONF/1ABF5D.REC.


I removed/returned power to 1ABF5D, power cycled PLM and ISY and still no joy.


Looking for help in fixing this problem with the fewest number of steps.



Link to comment



Thanks. Yes - restore from backup solved problem.


Wanting belt and suspenders, I did a device restore, too. Maybe not such a good idea.


Now ISY complains that it can't write to my wireless smoke bridge;


1) any quick solutions to stopping ISY trying to write to the smoke bridge?


2) any way, in the future, to do device restore without writing to wireless devices



Link to comment

All battery powered devices go to sleep to save battery life. Put the Smoke Bridge into linking mode with its Set button, right click the Smoke Bridge Primary node and select Write Updates to Device. If more that one battery device exists do ONE at a time. Be sure to take the battery device out of linking mode before starting the next one.


Restore Devices does all devices. There is a Restore Device for each device.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...