Jump to content

Keypad linc issues


Recommended Posts

I have a virtual 3 way in kitchen with 2 2477D dimmers that worked fine, maybe two weeks like this. All devices are connected through ISY994.


I replaced 1 2477D with 8 button keypad linc (dimmer version.) This switch has the actual load connected (ceiling fan light) Actual fan motor is controlled by non insteon switch.


I originally setup both devices as controllers in scene so both can control light on fan.


I have one button controlling an outlet linc in kitchen.


Was working fine for maybe a day or two, when Keypad linc locked up.


- The actual buttons themselves were frozen and wouldn't respond on the Keypad linc.


- Keypad led on button and load were responding to other virtual switch(2477D.) I was able to shut light on/off through ISY when locked up.


- Level 3 event viewer shows absolutely no traffic when pushing these buttons after lock up.


- The set button does not beep when pushed in after lock up.


- If I pull set button out to cut power, switch will work fine until it locks up again.


- I've factory reset switch.


- I see weird issues on some lockups. Switch will emit long beep, start flashing red. Load will start flashing, buttons will start flashing. These are random, sometimes it happens, sometimes not.


- I've tried two keypad lincs, both do the same thing. I ordered about a week apart, one from smarthome, one from amazon vendor. This was maybe two weeks ago.


- If I delete device from ISY, it starts working again without cutting power to it. If I never add to ISY, I've been unable to get it to lock up. Seems like once I start adding buttons as controllers is when it flips out.


Maybe I got 2 Keypads from bad batch?


Any t-shooting ideas I should look at? Any steps I should try with event viewer? Had ISY for about a month, so I'm still learning.


Thanks in advance!

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...