Jump to content

Turn off KeypadLinc Controller LED


mbrossart

Recommended Posts

Is it possible to turn off a KeypadLinc LED from an ISY 994i or prevent it from turning on in the first place?

 

Use Cases:

  • [*:4mb87fww]I have four buttons tied to a FanLinc (Fans High, Fans Medium, Fans Low and Fans Off). Since the Fans Off button turns the fans off, I'd like the button to turn off as well (or never come on in the first place).
    [*:4mb87fww]I have an "All On" button that turns on many many lights and fountains in a scene. I like my KeypadLinc to act as a status dashboard telling which components are on. Since the "All On" is not tied to a single device, I'd just as soon have the button LED turn off (or never come on).
    [*:4mb87fww]Similar to the point above, I have an "All Off" button that I would like to turn or keep off. Same reasoning as above.

 

What I've Tried:

  • [*:4mb87fww]I thought I read in the documentation that a Controller can also act as a Responder in the same scene. This would be fine if I could define Responder properties for the Controller from the Controller, but alas I cannot. In fact, I already achieve turning KeypadLinc LEDs on and off on the "All On" and "All Off" buttons (all except the "All On" and "All Off" buttons themselves) by defining the KeypadLinc buttons as well as the devices as Responders in the "All On" and "All Off" scenes.
    [*:4mb87fww]I tried adding the Controller to the scene as a Responder as well, but it would not allow the button to be defined twice in the same scene.
    [*:4mb87fww]I wrote the following program, but it didn't work...If Control 'Fans Off Button' is not switched Off Then Set 'Fans Off Button' Off. I tried several variations of this, but nothing worked.

 

Can anyone help?

Link to comment

“I have four buttons tied to a FanLinc (Fans High, Fans Medium, Fans Low and Fans Off). Since the Fans Off button turns the fans off, I'd like the button to turn off as well (or never come on in the first place).â€

 

Set the Fans Off button to non-toggle Off mode. The button LED will blink twice when pressed and turn Off. It will always issue an Off command in non-toggle Off mode.

 

 

“I have an "All On" button that turns on many many lights and fountains in a scene. I like my KeypadLinc to act as a status dashboard telling which components are on. Since the "All On" is not tied to a single device, I'd just as soon have the button LED turn off (or never come on).â€

 

Set this button to non-toggle On mode. The button LED will blink twice when pressed and turn On. Not what you want for the button LED but this will have the button always send a On command. Write a simple Program that says

 

If Control ‘buttonx’ is switched On

Then

Set Scene ‘xxxx’ Off.

 

Scene ‘xxxx’ has this KPL button as a Responder.

 

 

“Similar to the point above, I have an "All Off" button that I would like to turn or keep off. Same reasoning as above.â€

 

Set this button to non-toggle Off mode.

Link to comment

Thanks Lee. I forgot to mention that I also tried setting the buttons to non-toggle-off. Must be opposite day on my KPL because my 'Fans Off' button and 'All Off' button, set to non-toggle-off, both stay on. My 'All On' button, set to non-toggle-on', blinks twice and turns off.

 

First cut at your program suggestion didn't work, but since my two off keys were set to non-toggle-off, I modified the program to: If Control 'Fans Off' is switched Off Then Set Scene 'Fans Off LED Off' Off. That works.

 

If anyone has any suggestions to get me out of opposite day on my KPL, that'd be cool. If not, the end result is working as desired, so I guess it's okay.

 

Thanks for your help.

Link to comment

Not sure how to check the firmware on the KPL. Help|About shows v4.0.5.

 

Toggle/Non-Toggle was initially set manually as I didn't have an ISY. Once I found how difficult it is to set things manually, and be confident it's correct, I bought the ISY. I tried resetting the KPL to factory defaults per the KPL instructions and when I added the KPL to the ISY, I chose the option to 'Remove Existing Links'. Perhaps that didn't clear things as I would have hoped.

Link to comment

That option clears the link records only. It does not affect other KPL options. I would use the Admin Console to set the non-toggle modes. It is likely that the entire KPL will have to be set to the default toggle mode. Then set the individual buttons to the desired non-toggle mode. The KPL firmware level is displayed on the second line of the KPL information displayed in the right hand window.

Link to comment

Thanks. Yeah, I actually tried setting the whole KPL to toggle mode and changing the individual buttons. Didn't work. Firmware version is v.43.

 

Could be that we just have a mystery on our hands. It's not critical to solve as it's working the way I want it. It's just that the 'All On' button, set to Non-Toggle-On does not require additional programming and 'All Off' & 'Fans Off' do require additional programming. May not be worth much more effort. Just odd.

 

Thanks.

Link to comment
  • 2 weeks later...

I am having this same problem. New KPLs, same firmware v.43. Must be a bug in the firmware.

Setting a button to non-toggle ON or OFF have the same effect: once the button is pushed, it stays lit forever.

However, in the non-toggle ON mode, ISY recognizes that with the first button push the light comes on and stays lit. In the non-toggle OFF mode, ISY never recognizes that the button comes on - ISY always says the status of the button is OFF.

Link to comment

For what its worth, I have a new v43 KPLD8 that DOES NOT exhibit this behavior. I have 3 buttons configured as Non-toggle Off (B,G & H) and when pressed they blink twice and go off.

 

This replaced an older KPLD8 that died and was put in place with the replace function. Not sure if that should have any bearing on the situation.

 

-Xathros

Link to comment

Michel,

Sorry I missed your reply this weekend. I do have other all off buttons that work fine on other KPLs. I think I may have one brand new 8 button for back-up but not sure, it may be an single band 6 button. If I have it Ill try to manually set it to non-toggle off with my bench set up to see how it behaves. Then Ill add it to the ISY. If I don't have a new one, is there another way to trouble shoot it by checking events. I could reset and restore if needed.

Thanks,

Eric

Link to comment
  • 7 months later...

Sorry to bring up an old topic, but I never resolved this issue.  I have the KPL button that is set to non-toggle off, but the KPL stays lit.  I had discussed this with insteon support and they said they removed this function.  I just updated to 4.2.10 and did a device restore, but the button behavior did not change.  Any additional thoughts on this.

Eric

Link to comment
  • 2 months later...

I'm not sure if my issue is related to the above toggle issue but I'm trying to accomplish similar activities. 

 

I have a keypad link with the D button in toggle mode.  In a program "IF" statement, I test to see if the button status is 100%, and if so run the Action.   This works.  Then, after running the desired Action, I want to reset the button by turning off the backlight and setting the status to 0%.

 

To accomplish this I use "On 0/Off 0 (backlight level)" as an Action for the D button but that doesn't appear to set button D status to 0% (or less than 100%) as the activity keeps running.  However, the D button does turn off but apparently the D button status is still 100%.

 

What am i missing?

 

thanks, john.

Link to comment

John-

 

You need a scene containing only the KPL button as a responder.  Then just turn off the scene.  Adjusting the backlight levels affects the backlight brightness globally for all of the KPL's buttons and does NOT change the state of the button.

 

-Xathros

Link to comment

Archived

This topic is now archived and is closed to further replies.


×
×
  • Create New...