Jump to content

Programming with ISY and insteon dimmers


bcsh

Recommended Posts

I am using the isy and programming a few keypads with some dimmers.

 

my setup. 

6 2477D dimmers (insteon)

3 8 button keypads (insteon)

 

What I did is create a scene to control 6 lights with the one button on each keypad (button B on all keypads)

 

When I made the scene I dragged the 6 lights and 3 buttons into it. 

 

My issue is that when I press button B on one keypad it turns on the lights but does not turn on the keypad lights on the other keypads consistently.. any ideas or suggestions on how I can fix this? 

 

If you have any questions please do not hesitate and ask me.

 

 

Thank You

 

Link to comment

If a single ISY Scene with the three KPL buttons in red below the Scene name, are there pending writes (Green or Gray Icon with 1011 inside next to B button) ?   If not there is a comm problem between KPLs.

 

A Show Device Links Table of a KPL should show Controller links to the other KPL B buttons. 

 

Was that 50% test done by driving the Scene from the Admin Console or pressing  a C button.  Each Controller (PLM for Scene name or C buttons) have their own unique On Level and Ramp Rate values.  Make sure the On Level of 50% is set for all the responders of the Controller being used. 

Link to comment

Which 8 button keypad is this? Is it a pure keypad or the switchlic/dimmer that also controls load directly?

 

Also make sure if you are switching between testing the scene via the admin console and pressing the physical button that the scene level and controller level settings are the same - use the copy scene attributes on the controller node (the node in red text that is under the scene). Also if you don't have show devices heierarchically you might want to turn that on.

Link to comment

If a single ISY Scene with the three KPL buttons in red below the Scene name, are there pending writes (Green or Gray Icon with 1011 inside next to B button) ?   If not there is a comm problem between KPLs.

 

A Show Device Links Table of a KPL should show Controller links to the other KPL B buttons. 

 

Was that 50% test done by driving the Scene from the Admin Console or pressing  a B button.  Each Controller (PLM for Scene name or C buttons) have their own unique On Level and Ramp Rate values.  Make sure the On Level of 50% is set for all the responders of the Controller being used. 

 

After I created it I physically pressed the buttons and it does not work(to 50%) it turns on to (100%). When I go to test the scene on the admin console it does not work

Sat 02/07/2015 08:46:27 PM : [GRP-RX      ] 02 61 13 13 00 06 
Sat 02/07/2015 08:46:28 PM : [iNST-SRX    ] 02 50 2C.00.1F 33.60.28 E5 13 FF    LTOFFRR(FF)
Sat 02/07/2015 08:46:28 PM : [iNST-SRX    ] 02 50 2B.FE.87 33.60.28 65 13 13    LTOFFRR(13)
Sat 02/07/2015 08:46:28 PM : [std-Cleanup Ack] 2B.FE.87-->ISY/PLM Group=0, Max Hops=1, Hops Left=1
Sat 02/07/2015 08:46:28 PM : [iNST-SRX    ] 02 50 2B.FD.31 33.60.28 61 13 13    LTOFFRR(13)
Sat 02/07/2015 08:46:28 PM : [std-Cleanup Ack] 2B.FD.31-->ISY/PLM Group=0, Max Hops=1, Hops Left=0
Sat 02/07/2015 08:46:28 PM : [iNST-SRX    ] 02 50 2B.FD.31 33.60.28 61 13 13    LTOFFRR(13)
Sat 02/07/2015 08:46:28 PM : [std-Cleanup Ack] 2B.FD.31-->ISY/PLM Group=0, Max Hops=1, Hops Left=0
Sat 02/07/2015 08:46:28 PM : [iNST-SRX    ] 02 50 22.52.F3 33.60.28 65 13 13    LTOFFRR(13)
Sat 02/07/2015 08:46:28 PM : [std-Cleanup Ack] 22.52.F3-->ISY/PLM Group=0, Max Hops=1, Hops Left=1
Sat 02/07/2015 08:46:28 PM : [iNST-SRX    ] 02 50 22.52.F3 33.60.28 61 13 13    LTOFFRR(13)
Sat 02/07/2015 08:46:28 PM : [std-Cleanup Ack] 22.52.F3-->ISY/PLM Group=0, Max Hops=1, Hops Left=0
Sat 02/07/2015 08:46:29 PM : [iNST-SRX    ] 02 50 22.53.8C 33.60.28 65 13 13    LTOFFRR(13)
Sat 02/07/2015 08:46:29 PM : [std-Cleanup Ack] 22.53.8C-->ISY/PLM Group=0, Max Hops=1, Hops Left=1
Sat 02/07/2015 08:46:29 PM : [CLEAN-UP-RPT] 02 58 06 
Sat 02/07/2015 08:46:29 PM : [iNST-SRX    ] 02 50 22.5A.98 33.60.28 65 13 13    LTOFFRR(13)
Sat 02/07/2015 08:46:29 PM : [std-Cleanup Ack] 22.5A.98-->ISY/PLM Group=0, Max Hops=1, Hops Left=1
<html><font color="red">----- MasterbedroomDIM Test Results -----</font></html>
<html><font color="red">[Failed]</font> 101-MasterBed.001.B (2C 0 1F 2)</html>
<html><font color="red">[succeeded]</font> 101-MasterBed002-002.B (2B FE 87 2)</html>
<html><font color="red">[succeeded]</font> 101-002 (22 53 8C 1)</html>
<html><font color="red">[succeeded]</font> 101-MasterBed.003-003b (2B FD 31 2)</html>
<html><font color="red">[succeeded]</font> 101-001 (22 52 F3 1)</html>
<html><font color="red">[succeeded]</font> 101-003 (22 5A 98 1)</html>
<html><font color="red">----- MasterbedroomDIM Test Results -----</font></html>
Sat 02/07/2015 08:46:35 PM : [iNST-TX-I1  ] 02 62 00 00 13 CF 13 00
Sat 02/07/2015 08:46:35 PM : [iNST-ACK    ] 02 62 00.00.13 CF 13 00 06          LTOFFRR(00)

The 8 button keypad is model 2334-222 controlling 2477D

Link to comment

I just switched power bars just to make sure that wasn't it.... Now it seems that I cant get any commands happen when I send them from the admin console. 

 

Before I switched the power bars I got a warning saying "cannot communicate with keypad blah blah, please check connection. 

 

after I switched the power bar I had a warning that is now gone saying that my system is in safe mode. Plm defective.. 

Link to comment

I just switched power bars just to make sure that wasn't it.... Now it seems that I cant get any commands happen when I send them from the admin console. 

 

Before I switched the power bars I got a warning saying "cannot communicate with keypad blah blah, please check connection. 

 

after I switched the power bar I had a warning that is now gone saying that my system is in safe mode. Plm defective.. 

 

Power bar? Surge suppressor or power strip? The former will inhibit Insteon signaling.

Link to comment

I just switched power bars just to make sure that wasn't it.... Now it seems that I cant get any commands happen when I send them from the admin console.

 

Before I switched the power bars I got a warning saying "cannot communicate with keypad blah blah, please check connection.

 

after I switched the power bar I had a warning that is now gone saying that my system is in safe mode. Plm defective..

If you unplugged the PLM with the ISY running, this will happen. You should plug in the PLM, wait a little while and plug in the ISY.
Link to comment

I just fixed the one I had issues with. When a scene was activated it would say in the ISY console that the right ABCD button was lit but it wasn't.

 

I hard reset my KPDs set them to 3 retries for every button. Then did a complete restore of the device. Now working ok. In my case I think they were mis- programmed due to comms issues, despite multiple writes.

Link to comment

I just fixed the one I had issues with. When a scene was activated it would say in the ISY console that the right ABCD button was lit but it wasn't.

 

I hard reset my KPDs set them to 3 retries for every button. Then did a complete restore of the device. Now working ok. In my case I think they were mis- programmed due to comms issues, despite multiple writes.

I really hope that I don't have to do this.. I have 12 keypads with 40 devices that need to work properly or I will be getting a lot of calls. 

Link to comment

The connection issues seem to have cleared up. so I am able to control the dimmers through the admin console from universal devices. 

 

Is this the best way that I can program a system? before I programmed with the insteon hub app and I didnt have that many issues. I am using admin console now because it has different options that I need. 

Link to comment

I dunno, when I used the Revolv as a hub it controlled every scene - ie every device only had one association, with the hub and it didn't support the multi button devices.

 

I have had a steep learning curve with the 2334-232, they have been nothing but strange.

 

They key for me was ensuring I programmed at the scene level, used the copy settings to the controller in the scene and then test. I think my issues might have been excacerbated by some RF issues. So putting device retries to 3 on the 2334-232 seems to have cleared up my issues along with doing the full reset on the two problematic ones.

 

I have no idea if this is an insteon device / PLM issue / ISY issue oh and a bug in mobilinc was making me think I had devices issues I did not have...

Link to comment

I just dont understand. I just created another scene and it was created however the lights do not turn on to the level that I set them to, they just turn fully on.

 

You used the copy function to copy scene attributes to each of the scene controllers?

Link to comment
Michel Kohanim, on 08 Feb 2015 - 1:38 PM, said:

Hi Scyto,

 

Of course. I am open to anything that will make things easier to configure.

 

With kind regards,

Michel

 

:-)  I will need to think about it a bit more, but it seems many of us hit similar issues.

 

One idea I had for v5 was to treat (optionally) the keypad dimmers and switches as a virtual node.  Meaning that one could configure the buttons at both the scene level and controller level, i.e. never even expose the two levels, keeping them both in sync.

 

What I haven't given enough thought to is how this idea breaks for other scenarios, nor do I have enough insight to how insteon does it in their hub - maybe they came up with a different / better idea than mine.

 

I guess this also goes to the root of me not understanding the history wrt to button grouping too :-)

Link to comment

Archived

This topic is now archived and is closed to further replies.


×
×
  • Create New...