Jump to content

ISY and MorningLinc


Recommended Posts

When I upgraded my ISY to Alpha Version 5, I decided to start fresh on my home automation network.  Been quite a while since I added the MorningLinc to ISY, but when I did, I forgot this...


  1. Select the third option 'Add devices found in links and keep existing links'.
    • If you select 'Remove existing links' it removes all links from the MorningLinc and due to the security measures on the MorningLinc the PLM can no longer send commands to it.


So now the MorningLinc is added, but I cannot do anything with it.  How to correct this?  Do I link it with the PLM using the 'set' button on the PLM first?

Link to comment
  • 3 weeks later...

I have seen later firmware changes in many module that act differently than the manual.


This only a educated guess. From what I have seen in some later module. It may not do anything.


When you are holding the set button and connecting it. Does it start beeping? If it does. Keep holding the set button until the beeping stops.

Link to comment

Hello guys


Thanks for all the replies. I linked morninglinc with my lock and then I linked to ISY, but I erased the existing links.  After that nothing worked (tapping set button on morninglinc or commands thru isy was not working)


I tried to factory reset, but the device never beep and the led does not turn on while I'm holding the set button. I managed to link morninglinc to the lock again, but it very unreliable using set button (it was working fine before isy).  When I link it to isy with the correct procedure, nothing works again.


I think I need to perform the factory reset, but all the procedures I found failed. The morninglinc version is v.42.


Best regards



Link to comment

it very unreliable using set button (it was working fine before isy).  


The ISY is not involved with the comm between MorningLinc Set button and lockset.   Look for some change in position of MorningLinc to lockset.  Also batteries in lockset could be low reducing reliability.


Is this v.42 MorningLinc the old style with LED on side next to Set button or newer style with LED on top edge of unit?

Link to comment

Hey Guys-


I've been so busy lately, I haven't had time to reply to this, but I think I have the same MorningLinc as eduardo.  I thought the issue was resolved for me, but not so.


I get the same thing when trying to factory reset the MorningLinc.  Plugging in unit while pressing the set button for 1 minute (any amount of time) does not work.  I am still able to control lockset, so that tells me that a factory reset never takes place.


So it really boils down to why the MorningLinc is not doing a factory reset?

Link to comment

Thank you. I suspect this is more related to the MorningLinc firmware level rather than the hardware level which is on the paper sticker. The MorningLinc firmware level can be found on line 2, right side of Admin Console display of MorningLinc (either node). This MorningLinc has v.3A firmware where Factory Reset works as described in User Guide.


Link to comment

If I follow these steps:

- Pulled MorningLinc from outlet.  Waited 10 seconds.  While holding down set button, plug back in.  The LED will stay off until you let go (I held it for 20 seconds) and then the LED will come on (no factory reset).


If I:

- Pull MorningLinc from outlet.  Wait 10 seconds.  While holding down set button, plug back in.  The LED will stay off until you let go (I held it for 20 seconds and let it go).  Press and hold the set button (LED flashes fast, slow, etc.).  I let the button go after the LED went solid again.  Factory reset worked I assume cause the lock is no longer controlled by the MorningLinc.


I re-link the doorset with no issues.  Pressing set button locks and unlocks door.


Next, I try to add the MorningLinc to ISY.  Using the 'Start Linking' method (choosing option 3) and pressing the set button.  ISY never pops up with found device.  Tried Double-tap, single you name it.  Nothing.


Next, tried to 'New Insteon Device'.  Selected option 3 and enter name and address and select MorningLinc device (not auto-discover).  It proceeds to read and fully completes process with no errors.


This is why I thought problem solved before...  however, the controls in ISY to lock and unlock door are still missing?


I am running the Alpha 5.0, not sure if that may be the issue?

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...