Jump to content

Schedule to control dimming


GroverD

Recommended Posts

Hello,

 

I am using an insteon 2477D switch and to have have it set to come on at 10% between 10pm and 7am, but come on at 100% and be under the dimmer switch control outside of this time.

 

My program is:

If
     Control 'Kitchen lights' is switched on
 And from 10:00 PM 
        to 7:00 AM
then
    Set 'Kitchen Lights' 10%
Else
    No Actions

At this point, they *always* come on at 10%.  The whole idea is simply that you walk into the kitchen at 0-dark-thirty and instead of blinding yourself, the lights come on very dimmed. But any other time, they come on at 100%.

 

Obviously, I am missing something here. Any suggestions?

Link to comment

You only indicated what to occur during the specified time, but nothing about what to happen at any other time. Also dbuss is correct, you need to specify the next day in the From..To... statement.

Link to comment

Omission on my part. I do have next day in the statement. 

 

I will try adding the else 100% tonight when I get home.

You are commanding the light to go on with those levels at those particular times, not what level they will come on at, when turned on. Your OP "set to come on at"  seemed to indicate differently, wanting light level  presets for when they do come on.

 

 

Is this what you wanted to do?

Link to comment

You are commanding the light to go on with those levels at those particular times, not what level they will come on at, when turned on. Your OP "set to come on at"  seemed to indicate differently, wanting light level  presets for when they do come on.

 

 

Is this what you wanted to do?

I want to come in to my kitchen and turn the lights on. When the time is between 2200 and 0700 the next day, I want them to come on at a lower preset level. Any other time the lights are turned on at the *light switch*, I want them to come on at 100%.

Link to comment

ok - I went back and tore apart all my settings and found some of the issue and changed it a bit. Now it works.

 

One possible solution that works (what I did):

 

1) Select the switch and set it to come on at 10% lighting. Save and TEST it! You press the on button 1 time and it should come on at 10% lighting.

 

2) Write program:

If
         Control 'Kitchen lights' is off
     And Control 'Kitchen lights' is switched on
     And from 7:00 AM
         to 10:00 PM
then
        Set 'Kitchen Lights' 100%
Else
  No Actions

Since we have the default brightness set to 10%, the else clause does not need to do anything at all. Using this, I press the button and the come on dim - ALWAYS. Then the program runs and checks the time. If the time is between 7AM and 10PM, the brightness is adjusted to 100%.

 

I had too many places I had made changes/adjustments to various settings and they interfered with each other.

 

I suspect I could also add the setting for kitchen lights to 10% in the else statement. Testing has shown me this works but in this case we always come on to 100% and about 0.5 seconds later, we shift to 10%. I prefer coming on at 10% and then increasing to 100% about 05 seconds later.

 

Many thanks to all of you for your assistance.

Link to comment

ok - I went back and tore apart all my settings and found some of the issue and changed it a bit. Now it works.

 

One possible solution that works (what I did):

 

1) Select the switch and set it to come on at 10% lighting. Save and TEST it! You press the on button 1 time and it should come on at 10% lighting.

 

2) Write program:

If
         Control 'Kitchen lights' is off
     And Control 'Kitchen lights' is switched on
     And from 7:00 AM
         to 10:00 PM
then
        Set 'Kitchen Lights' 100%
Else
  No Actions

Since we have the default brightness set to 10%, the else clause does not need to do anything at all. Using this, I press the button and the come on dim - ALWAYS. Then the program runs and checks the time. If the time is between 7AM and 10PM, the brightness is adjusted to 100%.

 

I had too many places I had made changes/adjustments to various settings and they interfered with each other.

 

I suspect I could also add the setting for kitchen lights to 10% in the else statement. Testing has shown me this works but in this case we always come on to 100% and about 0.5 seconds later, we shift to 10%. I prefer coming on at 10% and then increasing to 100% about 05 seconds later.

 

Many thanks to all of you for your assistance.

You program should  never be true with two Switched On triggers. Take one out and only use one.

 

One of tricks I have used is to set a long ramp of the light with the 100%. Say about 3-4 seconds.

 

Now when the switchlinc Control On is detected and the time frame is met, turn the light on to 10% with a fast ramp on.

 

 

Actually thinking back...the opposite works better. Set the level so that the local (paddle) light level comes on at 10%.

Now with one program using the SwitchLinc control On beat the 10% with a fast On which is 100%. You won't even notice the delay and the local level will not be reset to 100% with a Fast On.

 

You can test this technique at the SwitchLinc. Hold the paddle to get the 10% and then turn the switchlinc off. Now double tap the paddle up. Turn off, then  back on with single taps. It remembers.

Link to comment

I stand corrected. The code is:

If
      Status 'Kitchen lights' is off
     And Control 'Kitchen lights' is switched on
     And from 7:00 AM
        to 10:00 PM
then
        Set 'Kitchen Lights' 100%
Else
  No Actions

If STATUS is off and it says it is being turned ON.

Link to comment

I stand corrected. The code is:

If
      Status 'Kitchen lights' is off
     And Control 'Kitchen lights' is switched on
     And from 7:00 AM
        to 10:00 PM
then
        Set 'Kitchen Lights' 100%
Else
  No Actions

If STATUS is off and it says it is being turned ON.

The status On line will cause you troubles if you ever add another line to the then or in the else section.

When you change the status the program will trigger again and run Else immediately. No further lines after the set Kitchen Light to 100% (if you added one) would execute.

 

The line isn't needed for your case anyway.

 

 

You can try it this way to see if you like it.

Set the local level to 10% on the SwitchlInc to start with,  by holding the paddle down to the lowest level you can get it to.

Tap it off. Tap it on.

 

Come back after 10 PM and try it again or change your time frame to test during the day.

Don't forget to set the time frame back 

 

Have fun with it. You can't break it :)

If
     Control 'Kitchen lights' is switched on
     And from 7:00 AM
        to 10:00 PM
then
        Set 'Kitchen Lights' Fast On
Else
  No Actions
Link to comment

Why are you doing it this way?  It seems like the hard way......

 

Set the "On Level [Applied Locally]" to 100% all the time on the device or scene. This will make the switch turn the light on Full.   Then use the original 10PM to 7am Set on to 10%.

 

If you actually want the switch on/off to be 10% during those hours then use "adjust scene"

 

If there is no scene because it's just a device, make a scene with just that device in it.

Link to comment

Archived

This topic is now archived and is closed to further replies.


  • Recently Browsing

    • No registered users viewing this page.
  • Forum Statistics

    • Total Topics
      36.6k
    • Total Posts
      368k
×
×
  • Create New...