Jump to content

I'm tired.... and I can't get into my admin console

Recommended Posts

I have been working all day long.   I haven't used my ISY in a few months, but I wanted to update some of my settings.   I can log into my ISY no problem.  I can see my device configurations.  I can change their status.  (I.e. turn off and on lights).   However I can no longer get to the admin console.   some window opens up and then immediately shuts down.  I have downloaded the admin.jnlp but everytime I try to open it it just flashes something and then goes to a window which says "view and track your downloads".... I'm in a loop.   I click on the download, it opens into some window I can't read because it immediately closes and goes back to "view and track your downloads" again.

Link to comment

ok... :-)…. I am guessing that the issue is Java compatibility.  

1.  When I opened (or tried to open) my ISY using Firefox, everything went ok up to and including access to the ISY and the dashboard/home page where I can click on devices, programs, etc.   However, if I tried to get to the admin console, I saw the "don't close" window and a small notation near  the bottom which said:  Java 2+ is needed.    PS...I couldn't find anything called Java 2+ on the Oracle site.

2.  When I opened (or tried to open) my ISY using Chrome, everything I saw in Firefox happened there too (including the request for Java 2+ )

3.  When I opened (or tried to open) my ISY using Edge, the same things happened as had been seen for Firefox and Chrome happened, EXCEPT I did NOT see the request for Java 2+.  

In all three cases, I could see the "don't close" window and if I clicked on the logo in the center of that window I was redirected to the ISY marketing/home page with info about the ISY products etc.

In all three browsers, If I used the jnlp launcher, I just got into the endless loop.    In all three browsers, if I tried the https (suggested above) I could not access the ISY.  The connection wouldn't respond and the browser would time-out.

So, finally I tried using IE  (not edge, just plain vanilla IE).    I used:  http://168.192.0.YYY:xxxx (where xxxx is my port address for the ISY, and YYY is its IP address).  and everything worked as it should.  The home page came up (as it had done for the first three browsers), but this time the admin console opened properly too.

My guess is that IE (on my machine) is keeping pace with the Java updates so it is up to date and the other three browsers are either dropping Java compatibility (Firefox) or not acknowledging the Java updates which regularly take place on my machine.  (I have no idea if this is true or not, and I have no idea how to force Edge or Chrome to recognize whether or not Java is running the latest version.)

Anyway, MANY THANKS TO PAUL for forcing me to rethink what my issues might be/were.   I am at least able to do household updates I was intending to complete yesterdate.


Meanwhile it occurs to me that I use TD Ameritrade's "Think-or-Swim" stock trading platform.  It appears to have an updating process where the dashboard involves a combination of network access and local application functionality.  Yet, that system doesn't seem to suffer the hic-ups that my ISY does if the Java engine isn't separately managed on the computer.  Would it be possible for an "Admin Console lite" version to be developed that would not involve dependency on these Java upgrades?..   In other words, I depend on the Admin Console to do updates to my household switches and rudimentary scene/programming....but I'm not a sophisticated ISY applications developer.  As long as I could do my simple minded wall switch adjustments and scene controls, I'd probably be happy running my ISY using Java 1.0 on Windows 4.0.... (or whatever)…. using a 20 yr old laptop (from my archived machines) dedicated to controlling the house.  

Since I don't use the Admin Console frequently, I get rusty and my proficiency deficiencies force me into this relearn the OS/Java/Applications environment.   So, my request:  Could the ISY development team build a simplified Admin Console that could be set up "once" and eliminate all this frustration people like me "enjoy?"...or could the ISY environment figure out how to make a simple launcher that would work without all the firewall/Java interface issues?


Don't get me wrong.  I enjoy my ISY.   However, my neighbors who enjoy seeing all the automation I have in the house, are quite turned off by the idea of getting into Smarthome by Insteon/Universal Devices if it requires a degree in Computer Science to operate....






Link to comment

Chrome, Firefox and Safari have dropped direct support for the java webstart launcher.  However you should be able to download the ISY launcher JNLP file, drag it to your desktop and just launch it directly by double clicking on start.jnlp and no browser. That's what's worked for me.


Link to comment

or could the ISY environment figure out how to make a simple launcher that would work without all the firewall/Java interface issues?

Did you try the links in Paul's initial response?  If not, here is the text:



Since we are getting into beta for 5.0.x, we decided to change ISY Finder such that it will figure out which version of the UI to use based on ISY's firmware. So, you don't have to keep reinstalling the Admin Console. Furthermore, you can launch the Dashboard from ISY Launcher.


1. Clear you java cache (Clear Java Cache)
2. Go to https://isy.universal-devices.com/start.jnlp
3. Click  on the desired ISY row and, from the menu, choose the Admin Console or the Dashboard


1. For additional instances, you need to start another instance of ISY Launcher
2. For 4.6.2 firmware and below, as well as 5.0.12 firmware and below, you will get the original ISY Finder when you lauch


When you click on the link in 2., choose "open".  From the new pop-up window, follow step 3.  Works good for me.

Link to comment

OK.  I can tell you that it worked on my version of Edge browser, as well as IE.  I can only tell you what I do....

Each time I update my ISY software (currently, I am on v5.13, I think), I go to this forum:


and I find the topic related to my software.  The first post in that topic are the instructions for downloading the software and for launching the admin console and dashboard.  When I click the link for the admin console, I save it to the desktop.  From then on, I access the admin console from the newly-saved desktop shortcut.  

Link to comment

Thanks oberkc, I'll try that.   The start.jnlp isn't working for me.  I have been opening IE, then entering the local net address for my ISY and logging in, then I try to open admin console and get routed through a sequence of steps that opens a Java page, and then eventually my admin console … but this ONLY works if I'm using IE. If I try any other browser, I'm in an infinite loop that gets me nowhere.   I'll try your suggestions.   Thanks 

Link to comment
Thanks very much to all who've posted and advised.   I've done an version update to the latest "official" version.   I will move to the 5.0 versions when an official release is done.   (I'm a bit nervous about using the Beta version, since I'm not really an expert at this stuff.)
You would never be able to tell. Some advanced users have found some minor bugs while others find none.

Sent from my SM-G930W8 using Tapatalk

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...