Jump to content

Bond node server Automatic Update failing (3.0.9 to 3.0.10)


rwsani99

Recommended Posts

This isn't an urgent issue for me as I'm having no current problems with version 3.0.9, but when I issue a restart of the node server, I get the following message in the Polyglot log file:

11/9/2022, 10:12:05 [pg3] info: startNs:: Bond
11/9/2022, 10:12:05 [pg3] info: startNs:: Bond is valid
11/9/2022, 10:12:06 [pg3] info: checkLicense:: Bond Valid perpetual license found.
11/9/2022, 10:12:06 [pg3] info: UPGRADE AVAILABLE for Bond from 3.0.9 to 3.0.10
11/9/2022, 10:12:09 [pg3] info: [Bond(3)] :: New Version detected: re-running install process...
11/9/2022, 10:12:15 [pg3] info: upload successful
11/9/2022, 10:12:15 [pg3] info: upload successful
11/9/2022, 10:12:16 [pg3] info: upload successful
11/9/2022, 10:12:16 [pg3] error: Node server update failed Bond :: Error: notices doesn't exist
11/9/2022, 10:12:16 [pg3] error: Bond automatic update failed

Link to comment

Somebody else had this problem last month. It was resolved by upgrading Polyglot v3 from 3.0.X to 3.1.X. If you are running ISY on Polisy, in the Admin Console use the "Upgrade Packages" button under the "Configuration" tab to upgrade all of your software, then log into PG3 and select "Restart Polyglot 3" from the "System" dropdown menu. 

Link to comment

It is a bug in 3.1.14.  There are a couple of different issues related to how it tries to determine if an update is available. To enable support for multiple versions of the same node server a number of things had to change both in the store entries and in PG3.  It's having issues dealing with node server that were installed from old style store entries detecting updates that now have the new style store entries.   I believe I have the issue above fixed and am working some of the other issues.

  • Like 1
Link to comment

@Goose66No, I don't think that would help.  

However, the node server can be re-installed to get the new version. From the store or from the purchased list, select install and there should be an option to re-install it in the existing slot.  This will install the latest version without removing any existing nodes or resetting the configuration parameters.

Link to comment
Guest
This topic is now closed to further replies.

×
×
  • Create New...