Jump to content

PG3 Store fails to populate (PC)

Go to solution Solved by Geddy,

Recommended Posts

While opening the PG3 store from my PC's,:

-The dashboard functions and populates

-The Node server store, does not load (see attachment)

-The "Purchases section"  DOES NOT Load


While opening the PG2 store from UD mobile:

-The dashboard functions and populates

-The Node server store populates

-The "Purchases section" DOES load


While attempting  to install a node from the store using UD mobile, the app crashes.




Edited by RedReiter83
Link to comment

@RedReiter83 on the right side there is a drop down box that appears blank in your screen shot. See if you can get that to open and select "Production Store". Then perform a hard refresh (Chrome is Ctrl+F5 (Windows)).

Please also note that the current version for PG3x is 3.2.1 (as of this posting). You are showing 3.1.36. Not that it is directly related, but please update to the current version to make sure it's not a lingering bug.

Report back after updating if you still have the issue.



Link to comment

I have updated both the PG3 and firmware

Store still opens with the same result, store does not populate

Have selected Production store and performed a hard reset. Still does not populate

FYI   Same issue with the "purchases" page

Tried both Chrome and firefox


Also still have the same scenario, when using UD mobile... It populates, but crashes when trying to install a purchased node.

ST Inventory


Link to comment
  • Solution

@RedReiter83  just in case this might have been a glitch in 3.2.1 please update to 3.2.2 (just released today).

After you update, try using a different browser.  I always use Chrome and it works fine. I've never seen it not populate the pull down where "production store" should show. You're on Firefox. Perhaps you're running a plugin or something that's blocking some portions of the site from loading. 

Try in a private browsing session and/or try in a different browser. 

When I tried in Firefox (and in Chrome) it never allowed the dropdown to be empty. Are you running any other VPN or internet security software that might block web from loading all aspects?

Last option is to click "System" -> "Switch portal profile" and log into the portal again. 


Link to comment
  • 2 weeks later...

Were you able to figure this out?  I have been having this problem for a while now.  Multiple reboots, updates, different browsers, same problem.  I have the same issue as you where the store is NOT defaulting to anything.  (Selecting production doesn't do anything either.)

Link to comment
6 minutes ago, smileyw said:

I have been having this problem for a while now.

Please open a support ticket with UDI to see if the can track down the cause of this.

  • What is your current version for Polyglot?
  • What device are you using?
  • What browser are you using?
  • Have you tried a different browser?
  • What computer OS are you running?

Perhaps @RedReiter83 can come back and update this situation. It's been two weeks. Certainly if they opened a support ticket this could have been resolved.

And just out of curiosity if you browse to this site what shows up for you:  https://polyglot.universal-devices.com/

Link to comment

@smileyw since we didn't get an update from OP on this issue it's not clear if they got it fixed with a support ticket. When you get the issue resolved please post an update to help others if it happens in the future.

Having used PG3x on multiple browsers and even different computers (Win10 and Mac (with very old macOS)) I'm not sure why it wouldn't load for some (randomly). 

Only thing I can think of is to be sure you clear the browser cache, don't run any pop-up blockers or plugins that might be blocking sites. 


Link to comment
This topic is now closed to further replies.

  • Create New...