Jump to content

ISY994i is my ISY Dead?

Go to solution Solved by Brian H,

Recommended Posts

My ISY994i has been working fine.  I moved it to to another room while doing home improvements and tonight I moved it back to the original location but it is no longer working. 

It boots and afterwards there are no lights on.  It has a static IP and I can ping it and open a web to the IP. I can see Devices and Scenes. However from here it goes wrong.  If I go to My Programs it shows "error, Loading: /programs/" .  Similar errors when trying to access other menus.

Trying to open the admin ioX Finder says "Not Found".

I have power cycled several times, moved the unit to another location, swapped out the network cord, tried powering it on with and without the Insteon wall plug(PLM?).

What can I do to get my ISY working?

Any ideas are welcome.




Edited by toddh
Link to comment
  • Solution

If the Power LED is not on.

Try a new power supply. We have seen reports of them failing, including one of mine. It is possible it had enough energy to power it but when powered down and back up. It did not have enough energy to restart correctly.

  • Like 2
Link to comment

Thanks for the ideas. 

After I posted the ISY came mostly back up.  It was responding to Alexa, I could access the Admin from my laptop(but not my desktop which I had used several days before) and Main looked normal and contained all the devices.  But the Programs section was empty. All my Programs were missing. 

This morning I can access the Admin from my desktop and everything appears normal.  The Programs shows all my Schedules.   The ISY is performing as expected. 

I will order another power cube.  I think I saw someplace while reading that it is 5V, I am sure I can find the specs here on the forum. 

Should I replace the SD card, and is it a simple process to do so?


Link to comment

The first thing I would do is a backup, if you don't have a current one.

It doesn't hurt to replace the SD card, especially if the ISY is older... I'm going to say 5 years but others may have a better range. That way you replace it on your terms.

I know there is a procedure for replacing the SD card on the wiki somewhere. My recollection for the procedure is to pick one of these:

  1. Copy the image of the current card to a new card using a computer that has an appropriate slot. Insert it in the ISY and restart.
  2. Backup iSY. Replace the card with a new one. Restore ISY



  • Like 1
Link to comment

I replaced the power supply with a 12V 2A and the ISY booted right up and is responding normally.  If possible it seems faster and more responsive than before, although that may be my imagination given the ISY would be power regulated. 

I have some spare SD cards around so I may replace it in the future.  It should be possible to test the existing card, but I will do that when I have some time.  Still in the middle of home improvements.

Happy to have my ISY and home automation working!

Thank you!!!



  • Like 2
Link to comment
28 minutes ago, toddh said:

I have some spare SD cards around so I may replace it in the future.

the ISY994 takes the micro SD so it's not just an "SD Card" that many might consider it being. 

Here are the steps in the wiki that @paulbates was referencing:


Be sure to read the "NOTE" at the top of the page


30 minutes ago, toddh said:

If possible it seems faster and more responsive than before, although that may be my imagination

Perception might be altered since it's working. Glad you got things working again. Make sure you make a current backup!


  • Like 1
Link to comment
This topic is now closed to further replies.

  • Create New...