Jump to content

How do I change Polisy IP to one in a IOT VLAN group?


david-4
Go to solution Solved by david-4,

Recommended Posts

I have all my IoT devices on a VLAN specifically for IoT. To do so requires that I change the third octet of the Polisy IP address to one in the VLAN group (xxx.xxx.40.xxx). I have a Unifi Router with DHCP enabled. I can successfully assign an IP address to the Polisy if I only change the last octet of the address, but when I try to assign an IP with a different third octet the Polisy IP does not change.

I can't change the IP address from within IoX because Polisy/IoX 5.7.1 defaults to DHCP and has disabled the ability to set a static IP address from within IoX. When I set my router to assign a VLAN IP address to the Polisy, The Polisy does not change its address. 

Are there IP address limitations hard wired into the Polisy? How can I change the address so it can join my IoT VLAN?

Link to comment

You probably did this but the write up doesn't say... did you power down / power up the policy after updating the static DHCP address for the policy in the router?

Typically the router will hold the IP address for X amount of time. Many iot appliances need to be restarted and ask again for their network info.

  • Thanks 1
Link to comment
48 minutes ago, paulbates said:

did you power down / power up the policy after updating

Yes. I performed a proper shutdown, remove the power source. I left it unplugged for about an hour before reconnecting the power. I also tried rebooting the router. I tried different ports on the switch and different switches. I even try changing the lease time. I've tried all these solutions many many times. I've been successful with every device except the Polisy.

Link to comment
1 hour ago, david-4 said:

I have all my IoT devices on a VLAN specifically for IoT. To do so requires that I change the third octet of the Polisy IP address to one in the VLAN group (xxx.xxx.40.xxx). I have a Unifi Router with DHCP enabled. I can successfully assign an IP address to the Polisy if I only change the last octet of the address, but when I try to assign an IP with a different third octet the Polisy IP does not change.

I can't change the IP address from within IoX because Polisy/IoX 5.7.1 defaults to DHCP and has disabled the ability to set a static IP address from within IoX. When I set my router to assign a VLAN IP address to the Polisy, The Polisy does not change its address. 

Are there IP address limitations hard wired into the Polisy? How can I change the address so it can join my IoT VLAN?

Probably should be done by your dhcp server - there should be a way to give static dhcp lease for a particular mac.

  • Thanks 1
Link to comment
2 hours ago, david-4 said:

I have a Unifi Router with DHCP enabled. I can successfully assign an IP address to the Polisy if I only change the last octet of the address, but when I try to assign an IP with a different third octet the Polisy IP does not change.

There's probably a command that support can give you through SSH to reset the network DHCP Lease on the Polisy. Even though you left it unplugged for an hour more than likely it's trying to pickup the old IP from the lease from your router even though it's changed. 

I agree with @kzboray to open a support ticket and get the best route that way.

https://www.universal-devices.com/my-tickets

Once you get this resolved please post the fix here to help others should they have this issue in the future. 

  • Thanks 1
Link to comment

I have no idea if these entries are significant, but I found the following lines in the Ploliglot log after I did a system restart:

polisy daemon[2872]: 12/18/2023, 13:29:39 [pg3] ^[[31merror^[[39m: Getting IoP UUID failed: Error: connect ECONNREFUSED 127.0.0.1:8080

and

polisy daemon[2872]: 12/18/2023, 13:29:59 [pg3] ^[[31merror^[[39m: stderr: pkg: Repository FreeBSD missing. 'pkg update' required
polisy daemon[2872]: pkg: Repository FreeBSD cannot be opened. 'pkg update' required
polisy daemon[2872]: pkg: Repository FreeBSD-base cannot be opened. 'pkg update' required
polisy daemon[2872]: pkg: Repository udi cannot be opened. 'pkg update' required

Link to comment
53 minutes ago, david-4 said:

but I found the following lines in the Ploliglot log after I did a system restart:

How did you restart the device? Did you just use the "reboot" button in Admin Console or perform a shutdown/power cycle or just a SSH command?

When was the last time you ran an update? 

I think it might be best to open a support ticket if you're getting errors like that in a simple restart process. 

Something might have gotten corrupted and need fixing.

  • Thanks 1
Link to comment
  • Solution

As suggested, I opened a ticket.

The problem has been solved thanks to Michel.

My understanding was that the IP address was set to a static address in the configuration file /etc/rc.conf. I suspect it had been carried over from a setting way back in an early version of ISY when you still could set fixed network setting. I had built my system back on ISY version 3.x and just kept upgrading then moved it to the Polisy. More resent versions are locked to DHCP and do not allow you to change network setting within the ISY. The config file held the network setting from the original installation.

The fix was to SSH into Polisy then edit the /etc/rc.conf file as follows:

find:

ifconfig_igb0="inet 192.168.1.56 netmask 255.255.255.0"

replace with:

ifconfig_igb0="DHCP"

remove: defaultrouter="192.168.1.1"

Then do:

sudo service netif restart

  • Like 2
Link to comment
1 hour ago, Geddy said:

How did you restart the device? Did you just use the "reboot" button in Admin Console or perform a shutdown/power cycle or just a SSH command?

When was the last time you ran an update? 

I think it might be best to open a support ticket if you're getting errors like that in a simple restart process. 

Something might have gotten corrupted and need fixing.

 

I had done reboot by pressing the button on the polisy box 2 times. And I ran an update within the last month. I will inquire about these errors. I think they are indipendent of my IP address problem. I was able to fix my IP address problem with Michel's help.

 

  • Like 1
Link to comment
Guest
This topic is now closed to further replies.

  • Recently Browsing

    • No registered users viewing this page.
  • Who's Online (See full list)

    • There are no registered users currently online
  • Forum Statistics

    • Total Topics
      36.6k
    • Total Posts
      368.1k
×
×
  • Create New...