Jump to content

SMTP - DNS errors


fastbird1

Recommended Posts

I am using v.4.2.22 and simply cannot get my ISY994-z to send and email alert.  I have tried to use the default box, and tried some things I have read using the gmail isyalerts@gmail.com.  I get the mail serve DNS error message.  Any ideas?  Here is my configuration attached.  Any ideas?  I have also tried various DNS settings.

 

I added another screenshot below as the problem persists.

 

post-1201-0-43665100-1425353895_thumb.jpg

post-1201-0-13908200-1425354006_thumb.jpg

post-1201-0-36518900-1425417606_thumb.jpg

Link to comment
Share on other sites

I am using v.4.2.22 and simply cannot get my ISY994-z to send and email alert.  I have tried to use the default box, and tried some things I have read using the gmail isyalerts@gmail.com.  I get the mail serve DNS error message.  Any ideas?  Here is my configuration attached.  Any ideas?  I have also tried various DNS settings.

 

Change your DNS server to 8.8.4.4 and try again.  I've been seeing widespread issues with 8.8.8.8 recently.  Additionally, your subnet mask looks wrong to me.  Shouldn't that be: 255.255.255.0 ?  With that mask I don't believe you can reach much of anything!

 

 

-Xathros

Link to comment
Share on other sites

The SMTP server is incorrect. Entered as "smpt.gmail.com" - smpt. should be smtp.

Excellent eye there Lee!  I did notice that in his second screen shot pool.ntp.org failed DNS lookup.  Still think both the DNS server and the netmask are problems there in addition the the incorrect smtp server name.

 

-Xathros

'

Link to comment
Share on other sites

Excellent eye there Lee!  I did notice that in his second screen shot pool.ntp.org failed DNS lookup.  Still think both the DNS server and the netmask are problems there in addition the the incorrect smtp server name.

 

-Xathros

'

 I tried that - can you check the router - see pic.

Thanks

post-1201-0-00267700-1425417693_thumb.jpg

Link to comment
Share on other sites

 I tried that - can you check the router - see pic.

Thanks

 

That pic shows you WAN (Public internet side) settings - we need to see the LAN side.

 

Click LAN in the router and look for Subnet and Gateway there.

 

I'm quite sure the subnet should be 255.255.255.0, Gateway was probably correct at 192.168.1.254 and set the DNS to 8.8.4.4

 

-Xathros

Link to comment
Share on other sites

With the IP address of 192.168.1.100 and the subnet mask of 255.255.255.0, then your default gateway MUST begin 192.168.1 - otherwise there can be no communication! Your gateway is 200.29.193.226.

Link to comment
Share on other sites

With the IP address of 192.168.1.100 and the subnet mask of 255.255.255.0, then your default gateway MUST begin 192.168.1 - otherwise there can be no communication! Your gateway is 200.29.193.226.

Thanks for everyones help.  I have changed per your recommendations and am posting the failed error I still get.  Any ideas?  Also is the attached error of gmail - 

Jeff

post-1201-0-49311900-1425438166_thumb.jpg

post-1201-0-03693000-1425438714_thumb.jpg

Link to comment
Share on other sites

The errors could be:

 

1) Invalid username or password. Do you have two-factor authentication?  If so - you need to setup a service password and use that as your SMTP password instead of your regular google password. If no two-factor auth - ignore this.

 

2) Invalid TLS or port settings. A common mistake is confusing port 587 (requires TLS) and port 465 (SSL optional - but sometimes required). You appear to have this setting correct.

 

3) Timeout. Mine is 4000ms - not sure if 1000 is enough for the TLS negotiation to complete.

 

4) Some servers will reject if the 'From' address does not confirm to RFC standards. Your 'From' address does not. You should probably set that to 'Jeff:isyalerts@gmail.com' so that an RFC compliant 'From' address is sent. This may not solve the issue though.

 

5) Network issue. You have a DHCP reservation for 192.168.1.100 - and your ISY has a static IP of 192.168.1.100. This is not normally an issue in this case - since the MAC address indicates that the reservation is for your ISY. PErsonally - I place devices with static IPs outside of the dynamic DHCP range to avoid the possibility of conflicts.

 

6) Network issue. Your gateway may or may not be in 'router' mode - or it may or may not be in 'bridge' mode. If 'bridge' - there is no NAT. That would mean your ISY could not talk to the Internet. According to the manual (http://setuprouter.com/router/huawei/hg532e/manual-1194.pdf) check the state of the 'Internet' light on your router - if off you device is in bridge mode and you'll need a NAT device. If on or blinking this is not an issue.

 

Next steps:

 

To further check the network - let's compare the ISY settings with your client PC settings. I cannot tell from your screenshots if Windows / MAC or Linux.  So,

 

Windows:  type the following commands and paste the output:

    ipconfig /all

    route print

 

Linux (some distributions vary - this is Ubuntu):

    ifconfig -a

    netstat -rn

 

Hopefully, not a MAC - I don't know that one!

 

Post the results and we'll compare with the ISY settings. This, on the assumption that your client machine can successfully access the Internet.

Link to comment
Share on other sites

  • 2 weeks later...

Archived

This topic is now archived and is closed to further replies.


×
×
  • Create New...