Jump to content

Blinking ERROR LED - replace ISY device


sandpiper

Recommended Posts

Hi all,

 

my isy994i is blinking, Tried to reseat the SD-card, tried to insert a new one. Still blinks. Assuming that the device is malfunctioning, I have ordered a replacement device. Now my question is: Can I simply move the SD-Card from the old ISY to the new one? Or do i have to restore a backup?

The backup that I have is not too old, but I still might lose some changes I made.

 

Thanks for your help!

 

Link to comment

No, I'll try this later today. I wanted to get a replacement moving asap, because I am running a Bed&Breakfast and really need my lights on :wink: And some of the lights are controlled with wired in devices that cannot be accessed easily to operate them manually.

If I don't need the replacement, I'll keep in on the shelf, just in case.

 

I know I can restore the backup. But I would prefer just to swap the SD-cards, then I can be sure to have the most recent programming.

 

And I am 8 hours away from home right now, so I can't play with it myself.

Link to comment

You have to format and then add the firmware back to the new SD Card. You can't just plug it in and it works.

http://wiki.universal-devices.com/index.php?title=ISY-99i/ISY-26_INSTEON:Replacing/Formatting_an_SD_Card

 

The SD Card from a ISY99i may not work with out doing some things like putting a later version ISY994i firmware on it. As the ISY99i could have no newer than 3.3.10 on it.

 

Calling UDI Support is a good idea. They should be able to step you through getting the new SD Card working or determine if there is a rare ISY994i failure.

Link to comment

No. The LED was still blinkng, so I thought the new card was not recognized either. I'll cerrtainly give that a try before I replace the device. Thanks for all the advice!

My question here is still: If this fails, can I swap the SD card from the old 994i to the new one?

Link to comment

The firmware and files are all stored on the SD Card. So when you put in the replacement. Your ISY994i had no firmware or files to run at boot time.

Best to ask UDI about using the original ISY994i SD Card if it was not what failed causing your error LED flashing.

If the failure is the ISY994i and not the SD Card. I would imagine using the SD Card from the problem controller should work.

Link to comment

I am on it right now, trying to initialize the new card. But the ISY does not let me in. Telnet connects to the iSY, asks for user and password and then Authentification fails. Is there a special password for telnet?

If not, I'll simply do a factory reset...

 

Edit: Got it, it fell back to admin/admin for some reason...

Link to comment

Quick update... Could not initialize the new SD-Card, so we replaced the ISY and the PLM. Restored the latest backup. Now I can see all devices and all programs. And I can switch all devices with the ISY.

 

BUT: The Scenes don't work. I can switch them on and off, the on/off-status in the ISY changes, but in real world the devices don't do anything. Same with the programs - they seem to run, but nothing changes.

 

Is there something I need to do to get my scenes working? If not, I can delete and re-create them...

Link to comment

The PLM is new to the Insteon/ISY installation.  Need a File | Restore Modem (PLM) to rebuild all the devices link databases with the new PLM Insteon address.  Leave the battery powered devices alone so they will fail the Restore Modem (PLM).  After all other devices have been rebuilt put one battery device into linking mode and select Write Updates to Device.  When that battery device is complete take it out of linking mode .   Put the next battery device into linking mode and repeat Write Update for that device.

Link to comment

Doesn't work... The Restore Modem (PLM) function only runs a few seconds. From what I read it should easily take an hour or more... And I have 42 devices, but I only see 28 Links in the PLM link list. There is something wrong here. Is there some special magic I could do? Is there a reset-Modem-Button or something? Or should I try "delete Modem" first and then re-run the restore?

 

Thanks for your help, guys!

Link to comment

Here we go.

 

I should add that I replaced the new modem (which came with the replacement ISY) with my old one. This is the one connected now. It had 141 links when I plugged it in - this sounds reasonable.

Then I did the Restore Modem (PLM) and now it only has 28 links.

 

 

post-5626-0-51946000-1426433406_thumb.png

post-5626-0-91693800-1426433436_thumb.png

Link to comment

The old PLM was installed last year in September.

We removed both the old PLM and the old ISY when the replacement came in. I was fighting the new combination until this morning, then I changed back to the old PLM.

 

Unfortunately I am 8 hours away from home right now, so I have to remote control my wife for all physical activity :wink: I gave her the instructions of how to do it and I believe she did it right. So yes, the ISY was unplugged when the PLM was changed.

Link to comment

The next step is to issue a Restore Device for the SwitchLinc.  If that brings back the required links there is a File | Restore Devices that will restore all the devices.

 

I'm concerned the ISY Backup file used was not current.  With the ISY powered down when the old PLM was installed, yet a Restore Modem (PLM) did not bring back the required links, the current ISY information does not appear current.  A Delete Modem (PLM) would create this problem but it was indicated that the command was not used. 

Link to comment

No, I did not use the Delete Modem command.

Did file - Restore Devices. Still only 30 Links in the PLM (I had deleted and re-added 2 devices) and the Device has lost one more link, see attachment.

 

It is the most current backup I have. It did not give me any error messages, I can find all the program changes that I recall, it has created all the devices and all the scenes, why should it NOT restore the links?

 

I can try the restore again if you think this might help.

 

Thanks for all your help, Lee!

post-5626-0-28225600-1426444156_thumb.png

Link to comment

The Restore Device should have restored the links.  Since it did not I assume the current ISY information does not indicate more link records are needed.

 

This is a SwitchLinc with a paddle, not a Responder only device?

 

The MH Porch Lights (assuming it has a paddle) must have a Controller link (starts with E2) that causes the device to notify the ISY of paddle operations.   Also there is no Responder link for an ISY Scene (starts with A2 and has PLM address as Controller).  

 

We've gone through all the steps that should have restored the device link database and PLM for that device.   Between the low record count in the PLM and the missing link records in the device, something is not current with the current ISY information.  I suggest opening a Ticket with UDI as there is nothing more I know to do.

Link to comment

Thank you for your time, Lee! Much appreciated!!!

 

Just for the heck of it - I tried to remove a device from a scene and re-added it. Then I let a program activate that scene. Only the new device came up, not the other devices in the scene. Guess I simply have to spend the rest of the day recreating my scenes....

 

The very same thing happened to me when my insteon hub died on me. The restore (houselinc) brought everything back, devices and scenes. The scenes (especially the schedules) just didn't work anymore. I thought this was just an insteon thing, so I changed to ISY. 

 

Kinda disappointed to have the same experience here!

 

I'll keep you posted...

Link to comment

sandpiper-

 

This is NOT normal by any means.  If you have a good backup, you should be able to recover all of the links both in the devices and the PLM.

 

Do you have any motion sensors or door sensors that could be creating traffic during the Show PLM links or restore PLM processes?  If so, this traffic could very well be interrupting these critical processes.  II have found it best to ensure no traffic happens during these processes.

 

Hope this helps.

 

-Xathros

Link to comment

Finally I am back to normal... I had to remove all devices from my scenes and re-add them. Now everything works like a charm.

 

I don't know what else to say or do - there was no error message indicating that the backup or restrore was incomplete or unsuccessful... No, I don't have any door sensors. But I had disabled a few devices that I don't need in the winter. Could this cause a problem? They were just disabled during the initial restore, I had enabled them later for test, but it didn't make a difference.

 

Anyway, I am happy now. Thanks for all your time, guys!

Link to comment

Archived

This topic is now archived and is closed to further replies.


×
×
  • Create New...