Jump to content

Adjust Scene?


Recommended Posts

I'm having a hard time figuring out this new "Adjust Scene" feature in 2.6.7.


I have a 3 switchlincs (two slave one load) and two keypadlincs all controlling the staircase lights. So, each of these switches can turn the stairs lights on and off so all of the switches are controllers and responders. I created a program that adjusts this scene to change the on level to 100 percent in the daytime and 40 percent at night.


Here's my program:


- No Conditions - (To add one, press 'Schedule' or 'Condition')



In Scene 'Stairs' Set 'Staircase Lights' 40% (On Level)

In Scene 'Stairs' Set 'Staircase (Slave Down)' 40% (On Level)

In Scene 'Stairs' Set 'Staircase (Slave Up)' 40% (On Level)



In Scene 'Stairs' Set 'Staircase Lights' 100% (On Level)

In Scene 'Stairs' Set 'Staircase (Slave Down)' 100% (On Level)

In Scene 'Stairs' Set 'Staircase (Slave Up)' 100% (On Level)



I execute this program from this one:



From Sunset

To Sunrise (next day)



Run Program 'Stairs On Level' (Then Path)

Run Program 'Guest Bath On Level' (Then Path)

Run Program 'Office On Level' (Then Path)



Run Program 'Stairs On Level' (Else Path)

Run Program 'Guest Bath On Level' (Else Path)

Run Program 'Office On Level' (Else Path)



As far as I can tell, the program looks to be running properly. I can also confirm that the "Stairs" scene shows the proper on level for the various switchlincs. Unfortunately, it's not working. Whenever I tap any of the switches, it always goes to 40 percent, day or night.


Am I misunderstanding this feature? Does it only work when the scene is executed from software, not local taps? Is there any way around the "air gap" issue so I can use this adjust scene feature for single switches such as a single bathroom light?



Link to comment

Hello Paul,


At present, the Adjust Scene command applies only to the scene as controlled from ISY, not from any other controller in the scene. I'm not sure whether parameter adjustments for individual controllers is planned for a future release, or not.


Unfortunately, there is no way for ISY to work around the reboot requirement for local settings to take effect on most INSTEON devices--that is an issue with the device firmware.

Link to comment



A modest suggeston: Set your devices to control the SCENE with an ON LEVEL of 40% and a RAMP RATE of, say, 1.0 or 2.0 seconds. Then, use a program (ELSE branch) to set the devices to 100% (not modify the scene, just do a normal 'SET "Staircase Lights" 100%'. This might give you an immediate response as the lights default to start to 40% and then the program (with its slight delay) kicks in to raise to 100%. The ramp rate might mask the delay?

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...