Jump to content

Dumb scene question.


Recommended Posts

So, very new to this stuff, but learning fast...

 

Trying to play with buttons, and use a scene, but having issues.

I watched a YouTube tutorial, but still struck out.

 

I have:
ISY994 IR Pro

2477D - Dimmer

2334-232 - 6 Button Keypad

 

The Dimmer controls the lights over my desk.

The KeyPad controls the lights outside my office.

 

As a programming test, I'm trying to program buttons A and B on the keypad to turn my lights on and off.

I'm trying to make button A turn the lights on.

I'm trying to make button B turn the lights off.

I do not want them to be toggle buttons.

 

I have buttons A & B set to non-toggle.

I created a scene called DeskTest.

I added the DeskLights and made them a Responder.

I added the A&B buttons, and made them a controller.

Now, I can turn on the lights with the DeskLights dimmer, but A&B will only turn them off.

 

No matter what i play with, I can only get A & B to turn the DeskLights off.

What am I missing?

 

 

 

 

post-8481-0-34675200-1479333499_thumb.jpg

post-8481-0-68651700-1479333499_thumb.jpg

post-8481-0-00459900-1479333500_thumb.jpg

post-8481-0-36288400-1479333500_thumb.jpg

Link to comment

So, very new to this stuff, but learning fast...

 

Trying to play with buttons, and use a scene, but having issues.

I watched a YouTube tutorial, but still struck out.

 

I have:

ISY994 IR Pro

2477D - Dimmer

2334-232 - 6 Button Keypad

 

The Dimmer controls the lights over my desk.

The KeyPad controls the lights outside my office.

 

As a programming test, I'm trying to program buttons A and B on the keypad to turn my lights on and off.

I'm trying to make button A turn the lights on.

I'm trying to make button B turn the lights off.

I do not want them to be toggle buttons.

 

I have buttons A & B set to non-toggle.

I created a scene called DeskTest.

I added the DeskLights and made them a Responder.

I added the A&B buttons, and made them a controller.

Now, I can turn on the lights with the DeskLights dimmer, but A&B will only turn them off.

 

No matter what i play with, I can only get A & B to turn the DeskLights off.

What am I missing?

The KPL buttons need to be set to "Non-toggle - ON"

As per Stu abobve create two scenes and make each button a controller to one scene, each.

 

IOW. You have an Off scene and an On scene and you turn either scene ON.

Link to comment
I have buttons A & B set to non-toggle.

 

Non-toggle ON, or Non-toggle OFF?  (Hint, probably should be non-toggle ON, but depends on answers to other questions.)

 

I added the DeskLights and made them a Responder.

 

Good

I added the A&B buttons, and made them a controller.

 

Also good

 

Another question to ponder: do you want the B button to be lit (A off) when the lights are OFF?  And the A button to be lit (B off) when the lights are ON?

 

While this can be done with two scenes, I do not believe it must be.  This can be done with the scene you have already created.  I suspect the problem you are having is that you don't have the responder levels set correctly.  In the scene, select button A.  Verify that the responder levels are set to ON (or chosen percentage) for the dimmer and OFF for the button B.  In the scene, next select button B.  Verify that the responder levels are set to OFF for BOTH dimmers and button A. 

Link to comment

Hey Guys, thank you so much, but I'm still just as confused.

 

I deleted everything, and started over.

 

I have the KeyPad.A and KeyPad.B buttons set to "Non-Toggle [Off]"

 

I created a scene called Desk ON.

I added the DeskLights (dimmer) as a responder.

I added the KeyPad.A button as a controller.

When I click on the scene DeskON it shows:
- DeskLights OnLevel 100

- KeyPad.A OnLevel 100

 

I created a scene called Desk OFF.

I added the DeskLights (dimmer) as a responder.

I added the KeyPad.B button as a controller.

When I click on the scene DeskOFF it shows:
- DeskLights OnLevel 0

- KeyPad.A OnLevel 0

 

When I click either A or B, the button flashes about 3 times, and very rapidly turns off the lights.

Pressing A or B will never turn on the lights.

 

So, still stuck.

 

I also followed oberkc's instructions for a single scene with mutually exclusive buttons.

I also tried following this YouTube video: https://www.youtube.com/watch?v=hbkFnzBhKB4, starting at 8:35.

 

Still can't get it to work.

I basically cannot get A or B to turn the lights on...

 

Can anyone post screenshots?

 

Thanks, Nick.

Link to comment

You have button A in non-toggle Off. The button will always send and off when pressed. The On button should be set to non-toggle On.

 

If you set the button to non-toggle On, then it will always be lit even if you press the Off button. To fix that, add the On button to the Off scene as a responder with an On-level of off (0).

Link to comment

My suggestion at this point is to slow down and take a little more time reading the responses.

 

- I said nothing about mutually exclusive buttons

- I asked a question about whether your buttons were in non-toggle-ON or OFF mode (still waiting on a response)

- I asked about the condition of the B button you wanted for the OFF scene. (Still waiting on a response.)

Link to comment

I think the Toggle was the key.

 

I assumed (wrongly) that "non-toggle (off)" was the opposite of "Toggle" - I never realized that there were 3 states...

 

I had gone back and checked they were in "non toggle" but didn't understand the on/off part of the question, which was key.

 

Okay, I'm on way way again.

Thank you.

 

Nick.

Link to comment
How to turn on/off the button lights.

 

Buttons are either ON or OFF.  If you don't want them lit, you can define the backlight levels to zero, but this is a global setting and there is no way that I am aware to separate individual buttons from the global backlight settings.

 

However, if all you want is the B button to turn off your lights and not be lit, then configure it Non-Toggle OFF, as you had before.  Leave button A as Non-Toggle ON.

Link to comment

Yep, this is my next question.

How to turn on/off the button lights.

Any hints?

 

You have button A in non-toggle Off. The button will always send and off when pressed. The On button should be set to non-toggle On.

 

If you set the button to non-toggle On, then it will always be lit even if you press the Off button. To fix that, add the On button to the Off scene as a responder with an On-level of off (0).

Link to comment

Okay, so after the dumb confusion (mine) over the toggle switches, I think I'm getting it.

 

So, in the scene, I have three items.

- DeskLights (responder)

- Keypad.ON (controller - button set to Non-Toggle ON)

- Keypad.OFF (controller - button set to Non-Toggle OFF)

 

With your guys' help (thank you) I have figured out:

When I click on KeyPad.ON I can see the DeskLights and the Keypad.OFF items.  Here I can set the lights to come on at a certain brightness at a specific ramp rate.  I can also set the KeyPad.OFF button light to OFF - so that when I activate the ON scene, it automatically turns off the B/Off button.

When I click on the KeyPad.OFF, I can see the DeskLights and the Keypad.ON items.  So, here I set the lights to go to 0% (off), along with the ramp rate.  I also set the KeyPad.ON button to be OFF.

 

When I click on DeskLamp, I see the same items as if I click on DeskLamp under the ISY node.  Specifically I see the current status, as well as the desired initial brightness and ramp rate.

Anything I change here is also changed under the main settings.  So this doesn't have any scene specific settings, just overall settings on what my wall switch does.

 

So, now my question.

When I click on the scene itself, I see all three items with brightness control.  What do these settings change?
 
Thanks, Nick.
Link to comment

Okay, so after the dumb confusion (mine) over the toggle switches, I think I'm getting it.

 

So, in the scene, I have three items.

- DeskLights (responder)

- Keypad.ON (controller - button set to Non-Toggle ON)

- Keypad.OFF (controller - button set to Non-Toggle OFF)

 

With your guys' help (thank you) I have figured out:

When I click on KeyPad.ON I can see the DeskLights and the Keypad.OFF items. Here I can set the lights to come on at a certain brightness at a specific ramp rate. I can also set the KeyPad.OFF button light to OFF - so that when I activate the ON scene, it automatically turns off the B/Off button.

When I click on the KeyPad.OFF, I can see the DeskLights and the Keypad.ON items. So, here I set the lights to go to 0% (off), along with the ramp rate. I also set the KeyPad.ON button to be OFF.

 

When I click on DeskLamp, I see the same items as if I click on DeskLamp under the ISY node. Specifically I see the current status, as well as the desired initial brightness and ramp rate.

Anything I change here is also changed under the main settings. So this doesn't have any scene specific settings, just overall settings on what my wall switch does.

 

So, now my question.

When I click on the scene itself, I see all three items with brightness control. What do these settings change?

 

Thanks, Nick.

The settings inside the scene (top line) set the "presets" in the scene that take effect when you send out "Everybody with scene number XX...do as you were previously told"

 

The settings for the devices, on the next lexical level, under the scene header, are copies of the devices webpages, and when you adjust those settings it affects the "local", preset, settings of the devices. ie. When you walk up to the SwitchLinc and tap the top of the paddle, what level it will go to and how long it will take. Scene presets are completely separate but still all stored inside the devices.

Link to comment
When I click on the scene itself, I see all three items with brightness control. What do these settings change?

 

A slightly different way of looking at it is to assume that all scenes have a controller device in them not listed.  That controller is the PLM.  The scene-level settings shown are those that would be achieved when the scene is activated by the PLM (or, rather, the ISY).  Activation by the ISY would typically be manually via the admin panel, or by program. 

Link to comment

Okay, feeling dumb again.

 

I'm having an issue with the LED lights on the KPL.

I have KPL ABCD buttons controlling the fan to Off, Low, Med, High.

 

I have A set to non-toggle.off

I have BCD set to non-toggle.on.

I have ABCD set to turn the LED's OFF for each of the other settings, so pressing B will turn off the LEDs on ACD, etc.

 

I'm trying to get the A button to turn OFF when pressed.

A is set to non-toggle.off.

When I press it, it turns off the fan, but turns on the A LED.

I've tried changing the button to non-toggle.on playing with it, and then setting it back to non-toggle.off.

I can force it off using the admin console, by sending an OFF to the scene.

I have the scene set with everything off.

 

I know I can do this with a program, but don't want to.

 

What am I missing here - how do I get button A to stay off when pressed?

 

Thanks, Nick.

Link to comment

Setting the button to non-toggle off should set the button to off at every push. It will blink twice, but stay off.

This is how it works for me, as well. I dont understand how a button so configured would stay on, unless there are other programs or scenes in play here.

Link to comment

Setting the button to non-toggle off should set the button to off at every push. It will blink twice, but stay off.

 

That's what I want to happen.

Doesn't happen that way.

I have the A button set to non-toggle.Off.

I press it, and it turns the fan off, but leaves the LED light on button A lit up.

 

I have everything set it one scene.

I am essentially using mutually exclusive buttons.

A is NT-OFF.

BCD are NT-ON.

All buttons turn off the other LED lights just fine.

All buttons leave their LED light on.

I want button A (my off button) to turn its light off when it's done turning off the fan.

 

I went as far as deleting all scenes, deleting the KPL.  Hard reset on the KPL.  ReAdopt the KPL, program the scene from scratch.

There are no programs addressing this KPL.

However, setting the button to non-toggleON and non-toggleOFF both leave the LED on.

 

Any other ideas?

 

Nick.

Link to comment

Nickp,

 

Out of curiosity, I started to experiment around with one of my own keypads buttons. I confirmed, in my case at least, that a keypad button that is not part of a scene or programs set in non-toggle-off mode will flash twice when pressed, then turn off...always.

 

However, I enabled a program which turns on this keypad button if any of a select set of devices are on (if this or that is on, then turn on button). At that point, I started to experience your problem...pressing that keypad button resulted in the button flashing a couple of time, then staying ON. Very strange, based on my expectations.

 

I want to play around some more to see if I can better understand. If I learn anything that might be of help, I will let you know.

Link to comment

I also want to be sure you are NOT using the "mutually exclusive" option in the keypad settings. Correct?

Hmm, not sure about that.

What setting are you talking about?

(I'm assuming I'm not, since I don't know what it is, but would like to hear what you have to say.)

 

Thanks, Nick.

Link to comment

Archived

This topic is now archived and is closed to further replies.


×
×
  • Create New...