Jump to content

Problem with AV device and state variables


firstone

Recommended Posts

I've been tying to set up AV devices. And by most part, they're working. Except things like set channel and set volume. Those don't seem to set state variables. Not even sure how to troubleshoot it.

 

Another issue is that variable substitution doesn't seem to work for network resources. I've looked at some posts and copy network resource set up and still it's sending request with variable name, without substitution. Path set to /tivo/set_channel/${tivo.set_channel}, mode to Raw Text or C Escaped. Software version 4.6.2.

Link to comment

Thank you. I've missed that part about user variables and assumed "dot" notation was just a way or naming variables and it would do by name substitution. The second part works now.

 

As for your first question, it's not tivo dvr that sets channel but rather tivo AV device in ISY Portal. Sorry if that wasn't obvious. 

 

But, everything seems to work now. Including skill setting variable. Thank you.

 

Another annoying thing, Alexa seems to have trouble with word "tivo". Most of the time it says "I couldn't find the skill tiv-O". I've tried "tivo", "teevo" and even tried saying it as "t-ai-vo", just in case. Worked sometimes but not reliable. Works much better as "dvr". Don't think this one is the problem with the skill though.

Link to comment
46 minutes ago, firstone said:

Thank you. I've missed that part about user variables and assumed "dot" notation was just a way or naming variables and it would do by name substitution. The second part works now.

 

As for your first question, it's not tivo dvr that sets channel but rather tivo AV device in ISY Portal. Sorry if that wasn't obvious. 

 

But, everything seems to work now. Including skill setting variable. Thank you.

 

Another annoying thing, Alexa seems to have trouble with word "tivo". Most of the time it says "I couldn't find the skill tiv-O". I've tried "tivo", "teevo" and even tried saying it as "t-ai-vo", just in case. Worked sometimes but not reliable. Works much better as "dvr". Don't think this one is the problem with the skill though.

Great!

Yeah, certain words are a problem for clarity.  The Google Home devices are even worse. "TV Lights" gets an assumption and turns on "TV Lights" as well as "TV". People tell me to use "Lamp" but I cannot call a bank of 21 bulbs and RGBW strips a "Lamp" :(

Here we would say "P-V-R". :)

Link to comment

Archived

This topic is now archived and is closed to further replies.


×
×
  • Create New...