Jump to content

Can't turn a scene off after V3 upgrade


craigf

Recommended Posts

I have just upgraded from V2 to the V3 skill. I followed the instructions per the wiki. In some of my routines I used scenes. When I update my routines (since the scenes were deleted during the upgrade) there is now way for me to control the scene. For example, I add and action, select smart device and choose control a scene. I then choose the scene I want and a big "NEXT" button appears. I click next and it adds the scene to my routine as "Turn on Spa at 50%"  I have tried everything and can't figure out how to get it to just turn on the scene or turn it off like it did in V2.

Any ideas why the Alexa app is acting this way?

Thanks,

Craig

Link to comment

Michel,

Thank you for the reply. I agree and that is part of my confusion/problem/issue. I have no idea why it says that and also as I recall I could also turn a scene off in the last version. I have checked the portal and is shows Alexa as a "Scene" so it shouldn't be confused at that. It also shows up as a scene under the Alexa app. I have tried deleting the skill, forgetting all the devices and then re added the skill ISY V3 and re-detected the devises. Any time I try and add an ISY scene to a routine, it adds it as "Spa: Turn On, 50%" (substitute "SPA" for any scene I try to add)

The items that are controlled by the scene are a  Switch (on/off), an IO Linc Relay, and a Keypad button. All of these are On/Off devices.

Any suggestions on what else to try or reset? It worked fine in V2. I'm not saying V3 is the problem, but during the upgrade is where things went bad.

Thanks

Craig

Link to comment

Michel,

Adding a device works properly with no problems. 

I disabled the V3 skill and deleted all of the devices and scenes. I then reinstalled the V2 skill and detected all of the devices. All of my ISY scenes now show up in the Alexa app under "Devices". The name of the device says it is a scene in parenthesis (eg Spa (Scene) ). I am then able to use the scene in a routine with no problems. I can turn it on or off. I reviewed the portal and my routines are correctly listed in the Alexa Category as a Scene.

So, something has changed in the V3 that makes the scenes be detected in the Alexa app as a Scene (which makes sense but doesn't work). It did work in V2 since the Alexa app detected the ISY scenes as devices which were then allowed and on or off state.

I then disabled the V2 skill and deleted ("Forget") all the devices and scenes. I then added the V3 skill again. (No changes to the portal). I then detected devices. As it did before, it added my ISY scenes to the Alexa app under scenes. It gave me the same issue as before. When I add the scene to a routine, it gives me no options and adds it to the routine as "Spa on at 50% brightness". I then went into the portal and changed the Alexa category to "Switch" for the Spa Scene. It then showed in the portal as a Device/Switch. I then went into the Alexa app and deleted all the devices and scenes. I then did a discover and this time it put the Spa scene into the Device category. I then tried to add it to a routine and it acts just like it did as when it was a scene. It does not give me any options and when I add it, the command is "Spa: Turn on, 50%"

So, I can go back to V2 and have it work, but I know you guys are trying to get rid of that version. Please let me know what to try next.

Thanks,

Craig

Link to comment

Michel,

I'm running into exactly the same problem as Craig: when I try to add a scene action to a routine the app shows "Alexa will turn on (scene name) to 50% brightness" , with an "add" button below.  All I want to do is turn the scene off.    I haven't done as extensive experimentation as he has, nor did I try this with V2; however I get this same behavior with all scenes and regardless of whether I have first turned the scene on in the routine (i.e. I added the scene to the routine "at 50% brightness, then tried to add another action to the same routine, this time to turn the scene off.  No luck).  ISY firmware and UI are both v5.0.14

John

Link to comment

ISY Scenes can be brightened and dimmed, but can't be set to an absolute brightness level.

In the V2 skill, we could give a scene the capability to be brightened and dimmed, without the capability to be set to an absolute level.

In the V3 skill, which uses the Smart Home V3 API, the brightness capabilities are combined. To retain the ability to brighten/dim a scene, we had to give it the "brightnessController" capability, which allows to brighten/dim a scene, but also set it to an absolute level. Of course, ISY scenes don't support absolute levels, so whenever we receive a request to set a scene to an absolute level, the scene will be turned on or off if the brightness level >=50% (on) or <50% (off).

With V3, the side effect in routines is that a scene looks like a dimmer which can be set to ab absolute level. 

Long story short, to turn on the scene in a routine, set the percentage >=50% to turn it on, and <50% to turn it off.

Benoit

Link to comment

John,

Just tried it and I see what you mean. I don't know why the Alexa App behaves this way. It may not like scenes with a brightnessController.

A quick fix would be to expose your ISY Scene as an Alexa device. In ISY Portal, edit your device and change the Alexa category to "light".

It will appear to Alexa as a device.

Benoit

Link to comment

Hi Benoit,

I have already tried that and even though it appears as a device (light), it still operates like it did as a scene. There is no option to change the brightness. I have tried every Alexa category in the portal and it still has the same problem.

Thanks, Craig

Link to comment
11 hours ago, craigf said:

Hi Benoit,

I have already tried that and even though it appears as a device (light), it still operates like it did as a scene. There is no option to change the brightness. I have tried every Alexa category in the portal and it still has the same problem.

Thanks, Craig

Thanks for reporting this. 

This is now fixed.

An ISY scene exposed as an Alexa light | switch | outlet can now be used in a routine. Please note that if it is exposed as a light, this will give you the option to set the Alexa device to an absolute percentage. Of course, ISY scenes do not support this, so if the percentage is >= 50%, it will be turned on, otherwise it will be turned off.

Also, an ISY scene exposed as an Alexa scene can also be used in a routine. However, it can only be activated (turned on). It can't be deactivated (turned off). Whenever Amazon adds the capability to deactivate/turn off the scene , this will work with ISY Portal. The scene is already marked as supporting deactivation.

In order to support scenes in routines, I had to do a breaking change and remove the capability to brighten/dim an Alexa scene. I think this is better in the long run.

Ref: 

 

Benoit

Link to comment
1 minute ago, inovermyhead said:

Benoit,

Yes, a similar thank you for fixing this quickly.   It seems like a slightly odd logical quirk to have to control a scene by calling it a device, but it does work fine.   Happy New Year!

John

Well, you can leave it as an Alexa scene, and control the scene in the routine. 

The Alexa app however only allow to turn on the scene. It does not support turning off the scene at this time.

If you need to be able to turn off a scene, the work-around is to expose it as a device.

Benoit

Link to comment
  • 2 weeks later...

I'm not sure you understand the entire issue..... forget brightness level.  My discovered scenes can not be turned off.  There is no option in the routine when I pick "Smarthome" and then my ISY scene.  I get the Next button on the Alexa app, and the confirm screen that says it will turn the scene ON.  So where is the OFF??  

I do not seem to have a way to control the scene other than turning it on.  Device work but not scenes.  I am using the Mobilinc skill.

Link to comment

Archived

This topic is now archived and is closed to further replies.


  • Recently Browsing

    • No registered users viewing this page.
  • Who's Online (See full list)

    • There are no registered users currently online
  • Forum Statistics

    • Total Topics
      36.6k
    • Total Posts
      368.3k
×
×
  • Create New...