Jump to content

Missing Node Server Slot


Recommended Posts

I was playing around with registering another node server, "slot 2".  I think I might have been trying remote (not sure) was probably doing something wrong.  I might have tried to delete slot 2 from the ISY.  Anyway, I do not have slot 2 available anymore and I should.  ISY shows slot 2 empty and there's no node servers configure on my Polyglot cloud.  I even removed what I had in slot 1 to start from scratch.  /var/polyglot/nodeservers is completely empty.  Now I see all slots available 1-25 except 2.  It must be stuck half configured somewhere.  Any idea how I can recover slot 2 and make it available again?

Link to comment
Share on other sites

@theitprofessor I have no idea how you'd delete profile information from a slot that's populated from Polyglot cloud.  This only applies to a locally instanced version of Polyglot (assuming that you're looking at your installation of Polyglot on your Polisy, since you're posting this in a Polisy thread).

Additionally, I don't know if things have changed with the newer versions of Polyglot installed on the Polisy (database schemas can change, so use the technique below at your own risk, or get confirmation from UDI if you're uneasy), but you might need to delete the data for slot 2 from the locally instanced database on you Polisy.  I've done this on my RPi when I've wanted to manage a problem that appeared to be similar.

At the command line as the normal 'admin' user: mongo polyglot --eval "db.nodes.remove({'profileNum':'2'})"

Like I say, this has worked for me in the past on earlier versions of Polyglot running on my RPi.  If for some reason this borks your local installation, you may need to drop the Polyglot database and start over.  There are instructions on how to do that in the "Inital Feedback" thread.


Link to comment
Share on other sites

@Michel Kohanim Well currently I have 1 node server installed “Hue” because I put it back in.  But when I posted this I had zero node servers installed.  I can remove slot 1 again if I need to.  It’s no big deal to re-add it.  And yes slot 2 was and is still missing.  Michel do you suggest I delete the data from slot 2 like Bumbershoot suggests?

Link to comment
Share on other sites

6 hours ago, theitprofessor said:

@Michel Kohanim No joy!

[admin@polisy ~]$ mongo polyglot --eval "db.nodes.remove({'profileNum':'2'})"
MongoDB shell version v3.4.23
connecting to: mongodb://
MongoDB server version: 3.4.23
WriteResult({ "nRemoved" : 0 })
[admin@polisy ~]$

Restarted Polyglot and Slot 2 is still missing

Well, it appears the issue isn't caused by Polyglot on your Polisy.  Does the "Node Servers | Configure" show the value of " -- Empty -- " for slot 2 in you AC?  Example: slot 10 in the screenshot.



Screen Shot 2019-11-27 at 3.43.07 PM.png

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...