Jump to content

Stuck migrating from ISY994 to eisy


bikerbobhain

Recommended Posts

I am trying to replace my ISY with the new EISY home.  I tried to follow directions but must have done something wrong.

What I can see:

1) My new EISY shows up (My Home) on the portal login.  The connection button is green.

2) The information tab shows ...

UUID: 00:***removed***
Alias: My Home
Product: 5226 eisy
External IP: ::***removed***
Internal IP: 10.0.0.35
Encryption used: TLS_AES_256_GCM_SHA384
Admin Console URL: https://my.isy.io/isy/.... (Suggested I remove these)
URL to ISY : https://my.isy.io/isy/....  (Suggested I remove these)
Features installed
OpenADR
Networking Module
Portal Integration - UDI
Z-Wave Module
A10/X10 Module

3) Portal License shows ...


UUID: 00:***removed***
Alias: My Home
License Active: Yes
License Expiry Date: 2024-10-12
Purchase History:

Date purchased Start date Expiry
2017-10-12 2017-10-12 2019-10-12
2019-10-04 2019-10-12 2021-10-12
2021-09-26 2021-10-12 2023-10-12
2023-10-12 2023-10-12 2024-10-12

4) Trouble shooting tips shows ...

Everything appears to be configured correctly!

5) Neither of the URLs (See item 2 above) will connect.

6) Under Maintenance the reboot tab says it will reboot but the EISY does not seem to reboot.

    A ping set to my internal address of 10.0.0.35 does not stop, so I don't think it is rebooting.

 7) After clearing cache and using the ISY Web Access tab.  I get a page...

      "https://my.isy.io/udajax/udajax.htm?mode=corp "   after selecting "Settings" 

       then "Clear Cache" (responds cache cleared}  then "Install Admin Console (Internet)"

       I get a page "https://wiki.universal-devices.com/index.php?title=Main_Page#Installing_the_Admin_Console_Icon_on_Your_Desktop"

       I then select Clear Java cache which I clear but removing  /home/bob/cache/icedtea-web (I'm on OpenSuSE Tumbleweed).

       I then select ISY Launcher  which downloads start.jnlp

       I then run start.jnlp  the IoX Fjinder appears and after a few seconds it fill in my device.  The first click yields a menu that

       shows a menu with System Console .... plus other stuff.  Any selection results in the menu going away and nothing happening;

       After the initial start its is just a window that seems to accept nothing.  You can seem to get any response.  The buttons at the buttons

       on the bottom work but selecting "Add" and entering the local IP results in "Not Found"

------------------------------------------------

The UD app shows the EISY as My Home and Connected but there is not much I can do with the app.  Under that it says ...

System home

ERROR: Requested ISY not online.  503 system not online

or not communicating with Universal Devices Portal

Veryfy your System is connected to network.  Try reboot

Rebooting changes nothing!

Edited by bikerbobhain
removed address info
Link to comment

I'm a little confused as to your exact conditions, so let's start at the beginning. Assuming you are on a Windows machine with Java installed.

Let's start by using the multi function button to check for updates - one button press of the button will upgrade packages.

Wait at least 30 minutes and then press the multi function button 5 times to reboot.

Before trying to access the admin console, wait at least 10 minutes for eisy to completely boot up. Access the admin console by using the IoX Launcher. Start by deleting your Java cache being sure to check all three buttons to delete all apps. Then download a fresh IoX launcher from here: https://isy.universal-devices.com/start.jnlp .

Here are detailed instructions: https://wiki.universal-devices.com/index.php?title=Main_Page#Installing_the_Admin_Console_Icon_on_Your_Desktop

Run the downloaded file and it will place an icon on your desktop that you will use to access the admin console.

If IoX Launcher doesn't find your eisy, go through these steps:

https://wiki.universal-devices.com/index.php?title=Eisy:User_Guide#Can't_Find_eisy

If you run into issues with any of the above try to describe what is happening and/or post screenshots, obscuring any sensitive information.

Link to comment

I'm on OpenSuSe Tumbleweed.  I have Java.  My old ISY worked so I must have a working Java install.

Of course the license got transfered so I can't use the old ISY.

I am aware of the install page and have read it several times.  I believe I have followed these instructions.

----------------------------------------------

I pushed the multi function button ...

Waiting 30 minutes ... OK time is up ...

pushing mf button 5 times

Waiting ... OK time is up

Cleared Java cache.

Downloaded new start.jnlp file and ran it ... see attached finder.jpg

Clicking on the finder gives me the menu.  Selecting "Admin Console (lan)

A brief spin icon followed by nothing.  Further clicking yields nothing (no menu) and no icon.

I see that in the title bar it read Not Found.  If this applied to the EISY I can say that it is there.

I can ping it ...

     PING eisy.local (10.0.0.35) 56(84) bytes of data.
    64 bytes from EISY (10.0.0.35): icmp_seq=1 ttl=64 time=0.287 ms
    64 bytes from EISY (10.0.0.35): icmp_seq=2 ttl=64 time=0.186 ms
    64 bytes from EISY (10.0.0.35): icmp_seq=3 ttl=64 time=0.256 ms
 

I can telnet to it ...

    noname% telnet eisy.local 8443
    Trying 10.0.0.35...
    Connected to eisy.local.
    Escape character is '^]'.
    ^[

   Connection closed by foreign host.

If I point a browser at https://eisy.local:8443/desc I get ... (see second attachment)

The UD app shows connected.  (My original ISY is not online.)  (see third attachment)Screenshot_20231211-214649_UDMobile.thumb.jpg.11d602fae24bf464980a89b27a4e0268.jpg

Well this is were I'm stuck and that is all I know :-(

finder.jpg

browser-return

Edited by bikerbobhain
Link to comment

Try shuting down the eisy with 6 clicks of the multifunction button and unplugging the unit when the light turns red wait 10 seconds and give it a while to start then try accessing it.  Sometimes eisy gets hung up and needs a complete power down to return everything to it's proper state.

Link to comment
9 hours ago, bikerbobhain said:

I'm on OpenSuSe Tumbleweed.  I have Java.  My old ISY worked so I must have a working Java install.

Admin console is designed to work on Windows or Mac's running Java 8. anything other than that, is undocumented. You will need to ask UD if they know if it will work on what you are running, however, they might not know.

As for what use to work, well there are a lot of things that fall in to that category. With changes and tighter security requirements, you can not assume what worked on a ISY994 will work on eisy.

Link to comment

Michel came through ...  This is the answer to this issue ...

Linux does not support Java reflection. What you need to do instead is to go to:

https://eisy.local:8443/admin.jnlp

That enabled me to talk to the EISY.  We are moving forward again!!!!

Thanks to all who responded and a special thanks to Michel who didn't give up on a tough problem.

  • Like 1
Link to comment
Guest
This topic is now closed to further replies.

×
×
  • Create New...