Jump to content

Harmony Hubs not discovered after installing new wifi router

Go to solution Solved by Jimbo.Automates,

Recommended Posts

Hello, I'm looking for some advice regarding getting the PG3 Harmony Hub node server back up and running.

I replaced my TPLink Archer 11000 wifi router last week with the new RIO ROUTER. I am not a tech person, so bear with me on terminology. I have managed to get my nearly 50 network devices back up and working including eIsy, Blue Iris, Alexas, Firesticks, Shields, Roombas, Harmonys, Bonds etc. I started to count up all my Insteon/Zwave/Zigbee devices that I have installed over the past 13 years, and currently installed on eIsy, and came up with 154. 😲 I also have several PG3 node servers setup, eIsyIR, Bond and Harmony.

So here's my issue, I have not been able to get PG3 HarmonyHub to discover my 4 hubs now that they've been moved over to the new Rio Router. I have deleted the node server, reinstalled, discovered, started, restarted, rebooted eIsy, etc, etc. It just won't discover the 4 hubs. It runs discovery but comes back with 0 hubs. I have enabled "share" to every device/room in the new Router. I just can't think of anything else to do. I tried to configure one of the harmony's ip address into the node server, which I wasn't sure of exact format, I just typed hostname in the key and the ip address in the value, and clicked save, still would not discover the harmony hub. I have eIsy connected via ethernet (not wifi) and all the harmony hubs have XMPP enabled. I'm suspecting it must be some setting in the router, but have been able to get everything else up and running just fine.

Any advice or suggestions on getting the node server to discover my 4 harmony hubs, would greatly be appreciated.


Edited by jpoje
Link to comment

Thank you so much for responding. Unfortunately, I haven't a clue on how to perform that task. I will go in the router's advanced settings and see if I see anything that says "allow discover packets".

If it helps, I do have my "ethernet" device room set up in the router to "share" to the "wifi" device room that the harmonys are located in and visa versa. My Bond hub which is wifi and located in the same "room" in the router as the harmonys, was able to connect through PG3 Bond node server to eIsy. I also have a wifi govee light connected through PG3 govee node server to eIsy.

  • Like 1
Link to comment

In router I found "diagnostic tool" and I selected "ping" and put in ip address to one of the harmonys and this is what I received: (looks like harmony is receiving packets?)

PING ( 56 data bytes
64 bytes from seq=0 ttl=64 time=18.297 ms
64 bytes from seq=1 ttl=64 time=3.274 ms
64 bytes from seq=2 ttl=64 time=3.962 ms
64 bytes from seq=3 ttl=64 time=2.029 ms
64 bytes from seq=4 ttl=64 time=20.555 ms

--- ping statistics ---
5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max = 2.029/9.623/20.555 ms

ping completed

Link to comment
  • Solution
29 minutes ago, jpoje said:

Thank you, but not sure if I am formatting correctly. Is this correct formatting?

Sorry, no.  Make the key a short <= 8 character unique name which will be used as the node address.  The instruction says:


Create a param with the name 'hub_uniqueid' where uniqueid is the address that will be used for the ISY node, and with a value like: { "name": "HarmonyHub FamilyRoom", "host": "" }

So make the Value: { "name": "HarmonyHub RomName", "host": "" }

Including the curly braces and all..  I could spend time to make this a better way, but it's so rarely used it hasn't been worth the effort.


Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...