Jump to content

Upgrade from 4.4.6 to 4.7.x before 5.x?


Bug994

Recommended Posts

Been on cruise control for a number of years with my Isy, but with Polyglot and a few other ideas I have with a basement remodel, thought I should get around to 5.x finally.

Any recommendation if it's helpful to update to the latest 4.x (4.7.3?) firmware from an old 4.4.6 and run on that for a while before making the jump?  Or should I just go from 4.4.6 to 5.0.16C (RC1) directly?

 

Thanks...

Link to comment
21 minutes ago, Bug994 said:

Been on cruise control for a number of years with my Isy, but with Polyglot and a few other ideas I have with a basement remodel, thought I should get around to 5.x finally.

Any recommendation if it's helpful to update to the latest 4.x (4.7.3?) firmware from an old 4.4.6 and run on that for a while before making the jump?  Or should I just go from 4.4.6 to 5.0.16C (RC1) directly?

 

Thanks...

- Backup current 4.XX and make two copies

- Update to 5.XX as outlined by the 5.0.16C thread.

- Backup the current 5.XX and Rock On Roll . . .

Link to comment
Just now, Bug994 said:

Cool - thanks for the quick response.  I will skip that interim step, then, and save myself some time.

No worries, but no matter what make sure you clear the Java Cache and select *Help -> About* to confirm the UI & Firmware are both the same. If there is a mismatch you may see odd behavior! 

Link to comment

  I am unable  to update from 4.7.3 to 4.7.5 as available in Admin console.  (Automatic Upgrade)  UI is at 4.6.2.  Why didn't it update when I upgraded to 4.7.3?  Automatic upgrade to 4.7.5 gives me the "Upgrade Failed :Failed uploading file (reported written size is invalid)"  Is this due to the mismatched Firmware and UI?  How do I update the UI to 4.7.3 so they match?

Eventually I would like to upgrage to 5.0.16C the Prerequisites: Say   -  You must use the 5.0.9 Admin Console or greater to upgrade to this release (5.0.16).  I don't have a 5.x.x Admin console.  Are the instructions written in the incorrect order?  I have downloaded the 5.0.16C zip file.  How can I install this if I don't have the 5.x.x Admin console?  Someone needs to make these upgrade instructions clear for various upgrade paths!

Link to comment
  I am unable  to update from 4.7.3 to 4.7.5 as available in Admin console.  (Automatic Upgrade)  UI is at 4.6.2.  Why didn't it update when I upgraded to 4.7.3?  Automatic upgrade to 4.7.5 gives me the "Upgrade Failed :Failed uploading file (reported written size is invalid)"  Is this due to the mismatched Firmware and UI?  How do I update the UI to 4.7.3 so they match?

Eventually I would like to upgrage to 5.0.16C the Prerequisites: Say   -  You must use the 5.0.9 Admin Console or greater to upgrade to this release (5.0.16).  I don't have a 5.x.x Admin console.  Are the instructions written in the incorrect order?  I have downloaded the 5.0.16C zip file.  How can I install this if I don't have the 5.x.x Admin console?  Someone needs to make these upgrade instructions clear for various upgrade paths!

 

- Make sure the computer you’re on is running the latest Java if not update it. Verify that UDI is correctly listed in the application.

- Firewall: Ensure Windows or third party anti virus is not blocking the upgrade.

- 4.XX Make a back up of your current system now so you can skip that step during the upgrade process.

- Programs / Network Resources: Disable any of these that run actively like counting programs.

- Motion Sensors: Avoid moving around or disable these devices.

- 5.XX: Go to the 5.0.16C thread and down load the Z-Wave / ZigBee version of firmware doing so will allow the 994 Series Controller to continue to operate should your 2413S PLM Fail. Down load the Admin Console / Launcher called out at the bottom of the same thread.

- Install 5.XX and kick back a few cold ones while it loads. As noted up above once complete make another system back up. Verify all programs do not have any yellow error messages. If so resolve until gone.

 

Good luck

 

 

Sent from my iPhone using Tapatalk

Link to comment
14 hours ago, Teken said:

Install 5.XX and kick back a few cold ones while it loads.

Thanks for the help on this - had to chuckle because I couldn't possibly drink beers that quickly.  Very easy upgrade and everything seems to be working pretty well so far...  Even got polyglot going in short order last evening as well!

Link to comment
Thanks for the help on this - had to chuckle because I couldn't possibly drink beers that quickly.  Very easy upgrade and everything seems to be working pretty well so far...  Even got polyglot going in short order last evening as well!





Sent from my iPhone using Tapatalk
Link to comment

Thanks for the suggestions, but I am not having any luck upgrading to 4.7.5 or 5.0.16.  I either get the error that my UI is not compatible with installed admin console version or  "Upgrade Failed :Failed uploading file (reported written size is invalid)". I'm using the v.5.0.16C Admin Console.  I have the latest Java (C:\Program Files (x86)\Java\jre1.8.0_241\bin\javaw.exe).  That is the only thing that shows up in the java console Java tab.  I have no idea what else to add there.  My Admin Console Run target is:

C:\ProgramData\Oracle\Java\javapath\javaws.exe -localfile -J-Djnlp.application.href=http://isy.universal-devices.com/994i/4.6.2/admin.jnlp "C:\Users\Ken\AppData\LocalLow\Sun\Java\Deployment\cache\6.0\48\719ee830-7b8308c8"

Where or how can I download the user interface that is compatible with firmware 4.7.3. My UI is currently 4.6.2.  Firmware and UI need to be the same version and they are NOT.  I don't know why.  I am assuming that Admin Console and UI terms are synonymous.  I want to upgrade to firmware 4.7.5 first.

Please read my original post before replying and answer those questions if you can.  Thanks - this is very frustrating.

Link to comment
Thanks for the suggestions, but I am not having any luck upgrading to 4.7.5 or 5.0.16.  I either get the error that my UI is not compatible with installed admin console version or  "Upgrade Failed :Failed uploading file (reported written size is invalid)". I'm using the v.5.0.16C Admin Console.  I have the latest Java (C:\Program Files (x86)\Java\jre1.8.0_241\bin\javaw.exe).  That is the only thing that shows up in the java console Java tab.  I have no idea what else to add there.  My Admin Console Run target is:
C:\ProgramData\Oracle\Java\javapath\javaws.exe -localfile -J-Djnlp.application.href=http://isy.universal-devices.com/994i/4.6.2/admin.jnlp "C:\Users\Ken\AppData\LocalLow\Sun\Java\Deployment\cache\6.0\48\719ee830-7b8308c8"
Where or how can I download the user interface that is compatible with firmware 4.7.3. My UI is currently 4.6.2.  Firmware and UI need to be the same version and they are NOT.  I don't know why.  I am assuming that Admin Console and UI terms are synonymous.  I want to upgrade to firmware 4.7.5 first.
Please read my original post before replying and answer those questions if you can.  Thanks - this is very frustrating.


What firmware are you using now? If it’s 4.6.2 than go get that UI (Admin Console) from that specific thread. Once in place go back and confirm both match.

If they do make a good back up copy. Next download what ever 4.XX / 5.XX firmware you wish and follow all the steps outlined by the release notes. As always, please consider reaching out to UDI directly so they can assist you remotely if none of the steps here work.


Sent from my iPhone using Tapatalk
Link to comment

Archived

This topic is now archived and is closed to further replies.


×
×
  • Create New...