Jump to content

Can't connect with Polyglot V3 (PG3) from ISY Finder selection


SSamuels

Recommended Posts

Where I am:

·         Setup Polisy

·         Restored ISY backup from ISY994i

·         Updated Polisy firmware to v.5.3.0

·         Polyglot subscription is associated with my Polisy

All of my Insteon nodes are present and functional

Status - See image attached

 

First issue:

When using ISY launcher and selecting Polyglot V3 (PG3), Chrome attempts to connect to: 192.168.1.50:3000 and returns “This site can’t be reached”,“192.168.1.50 refused to connect”.

 

I presume I should be using PG3 to add nodes to Polyglot on Polisy and NOT Polyglot V2 (Deprecated), is this correct?

 

Thanks for any help

Samuels_PolisyStatus20220220.png

Link to comment

@SESamuels I had just the same experience trying to get PG3 to start running. 

First, do you know how to use Putty to gain SSH access to the Polisy? If so what is the current output of this command:

sudo uname -a

You should see something like this:   "FreeBSD polisy 13.0-RELEASE-p6 FreeBSD 13.0-RELEASE-p6 #16" 
Date should be close to Wed, Jan 12

If you do not know how to access via SSH and Putty or if you aren't on this version please refer to the Wiki for Polisy User Guide to get the process to connect and the commands to update to latest package.

Assuming you do see this version (or once you've updated) please try the following commands (each line is an individual command:

sudo service pg3 stop
sudo service polyglot stop
sudo pkg delete pg3
sudo rm -rf /var/polyglot/pg3
sudo service polyglot start

Change the port for polyglot (v2) to 443   (Mine was already on port 443, but sometimes older PG2 setups was using port 3000. But log into PG2 dashboard then go to Settings -> Polyglot Settings -> Polyglot Web Port. Logout of the PG2 dashboard.)

sudo service polyglot start
sudo pkg install pg3
sudo service pg3 enable
sudo service pg3 start

 

Apparently this process is needed for some Polisy that are coming from older build versions. I've only had the Polisy for a few months and had to go through this process just this week to try to get access to PG3. Chrome (as well as Firefox and Edge) were all giving me the "could not connect" error. Thankfully I got help in a support ticket. So hopefully this will work for you as well. Let us know either way. 

 

 

Link to comment

Thank you Geddy for the quick response.

First I need help getting into the Policy via PuTTY SSH - 

I downloaded Putty and on the Putty configuration page I enter the IP address of my Polisy. When I hit OPEN it brings up a ''cmd" looking window named 192.168.1.50 - PuTTY (this is the correct address of my Polisy. The prompt is: "login as:" I enter "admin@192.168.1.50" and am prompted for "Password for admin@192.168.1.50@polisy" I had changed my user id and password for the Polisy and when I enter my admin password, I get the response: "End of keyboard-interactive prompts from server - Access denied". Same result if I enter 'admin' as the Password.

I did check the link to the Polisy User Guide but could not locate any instructions on how to use PuTTY to connect to my Polisy.

Any ideas?

Link to comment

Hi tmorse305-

Thanks.

No love with login: admin@192.168.1.50 and password: admin

I had previously changed my Polisy userid to SESamuels and password for the 'Admin user' (File --> Set Userid/Password

I also tried to login: SESamuels@192.168.1.50 and used my new password but got the same refusal response.

What can I try next?

PuTTY_Login_admin_admin20220220.170512.png

Link to comment

@SESamuels Yes - follow the link to the wiki. Find the section for OS Version Below 13. That gives you what you need.

 

sudo shutdown -r now

curl -s https://pkg.isy.io/script/update121.sh | sudo bash
sudo shutdown -r now 

There could be some delay between the curl and when the unit is ready to run the shutdown command. Allow it to finish before typing in the window.

Wait for the unit to reboot (could take several/many minutes. You should hear a beep. Let it run...don't be tempted to think it will be quick.)

SSH into Polisy again

Then enter these commands:

cat /usr/local/etc/udx.d/static/update13.sh | sudo bash
sudo shutdown -r now

Again...wait for the unit to reboot. It could take another few minutes before you hear the beep. (NOTE: I think I got impatient and power cycled the device...not a good idea!)

After you hear the beep from the shutdown you can SSH into Polisy again. It should look a little different. To be sure it updated type the "uname" command again. You should now be on a more recent version. 

sudo uname -a

It's quite possible that since you're updating this way you might not need the commands in my prior reply, but more than likely you will. Try the launcher and see if you now have the additional entries and try to access the PG3 dashboard. See if Chrome gives same error. If it does then proceed with the post above for the commands to get PG3 running and listening.

Let me know if you're up and running. Good luck! 

Link to comment

Peeling away the onion...

I successfully upgraded FreeBSD Polisy, however the command: sudo service pg3 stop threw an error

FreeBSD polisy 13.0-RELEASE-p6 FreeBSD 13.0-RELEASE-p6 #16 releng/13.0-n244774-b                                                                                                                      0c8bc5d9cd: Wed Jan 12 18:39:31 UTC 2022     ec2-user@bsdev.isy.io:/usr/obj/usr/                                                                                                                      src/amd64.amd64/sys/POLISY  amd64
[admin@polisy ~]$ sudo service pg3 stop
pg3 does not exist in /etc/rc.d or the local startup
directories (/usr/local/etc/rc.d), or is not executable
[admin@polisy ~]$

What is my next layer of the onion? 

Thanks, I appreciate everyone's help 

Link to comment

@SESamuelshave you tried to access the Polisy web ip again with :3000 behind it? Since you didn’t have the new OS you might not have PG3 running and it would just work.  

Are you able to access PG2? 

What does your launcher show now? Does it see the Polisy?

If PG3 isn’t running then run the second set of commands in my first reply above.  It should start and enable the service.  

sudo service polyglot start
sudo pkg install pg3
sudo service pg3 enable
sudo service pg3 start

 

If this doesn’t work then start a support ticket. Thought it would be like what I ran up against since it appeared to give you same troubles I had.  Sorry it’s taking a while to get there. It’s worth it though. Good luck!

if you do get help from support be sure to post the steps they had you do to help others in the future.

Good luck!

Link to comment

Where I am:

·         Setup Polisy

·         Restored ISY backup from ISY994i

·         Updated Polisy firmware to v.5.3.0

All of my Insteon nodes are present and functional 

With the help of the forum, I was able to access Polyglot V3 & Polyglot V2 running on Polisy. I am attempting to register the node servers I had when using ISY994 & Polyglot cloud.

In Polyglot V2 NodeServers à Add NodeServer the first available NodeServer is my Autelis-Jandy that I had previously on my ISY994.

I select:

Node Server Type – Local (Co-resident with Polyglot)

Available Node Servers – Autelis-Jandy

Available Node Server Slot – 1 (There are no NodeServers in my AC on the new Polisy)

When I select Submit, I get the Add NodeServer message. When I select Confirm I get an error message – “ISY not connected to Polyglot. Can’t add NodeServers.”

The status box in the Register New NodeServer screen shows

“ISY Version: 0.0.0”

“Uptime 3Day(s) 20 Hour(s) 43 Minutes… etc. and is incrementing”

See Screenshot attached.

 

Suggestions for the next layer of this onion?

Thanks, as always.

AttemptToAddNodeServerToNewPolisy.png

Link to comment

Back at the onion.

Polyglot V2 successfully connected to my Polisy.

Added Autelis-Jandy NodeServer to Polyglot, slot #1

Specified userid, password and sessionTTL

Polyglot shows NodeServer  ‘Connected’

NodeServer Node Details – See image attached

 

Polisy Jandy-iAqualink (I renamed it this) Node in Main (n001_Controller – Pool Controller) show NodeServer Online = TRUE, but all other sections of the display are blank – See image attached

 

Polisy à Node Servers à Autelis-Jandy à Add All Nodes seemingly does nothing

 

Previously on my ISY994i I had this NodeServer connected successfully and was able to control all my Jandy iAqualink functions.

 

Thanks

 

Polyglot Node Details Autelis-Jandy.png

Polisy Jandy NodeServer display20220226.141957.png

Link to comment

Archived

This topic is now archived and is closed to further replies.


×
×
  • Create New...