Jump to content

Controls not working

Go to solution Solved by Panda88,

Recommended Posts

I have not really used this node server for anything but to show status until today I tried to setup so I could turn the seat heaters on before heading out without opening the app on my phone but the commands don't seem to work but I can see the state change from action done in the app when I update data. Below is the error I see in the log

2022-12-16 20:04:48,965 Command udi_interface.interface ERROR interface:_handleInput: _parseInput: failed climate1.runCmd(SEAT1) unhashable type: 'dict'
Traceback (most recent call last):
File "/var/polyglot/.local/lib/python3.9/site-packages/udi_interface/interface.py", line 795, in _handleInput
File "/var/polyglot/.local/lib/python3.9/site-packages/udi_interface/node.py", line 165, in runCmd
fun(self, command)
File "/var/polyglot/pg3/ns/EDITED_5/TeslaEVClimateNode.py", line 225, in evSetSeat0Heat
self.TEV.teslaEV_SetSeatHeating(self.EVid, 0, seatTemp)
File "/var/polyglot/pg3/nsEDITED_5/TeslaCloudEVapi.py", line 856, in teslaEV_SetSeatHeating
seats = {{'frontLeft':0},{'frontRight':1},{'rearLeft':2},{'rearCenter':4},{'rearRight':5} }
TypeError: unhashable type: 'dict'
Link to comment
18 minutes ago, Panda88 said:

I believe I fixed it already - it was one of my first python projects and I have no way to test the control code, as I do not have a car to test it on 

Sorry the seat heaters still are not working I sent you a log last night on version 0.2.17

Link to comment
10 minutes ago, Panda88 said:

Is there any chance I can get you to try the release in non-production store - There are some fixes there 

I want to release it but do not have a good way to test 

I can check it out later tonight after work. Thank you for working on this.

Link to comment
4 hours ago, Panda88 said:

Thanks - I will be travelling so out of reach for a little while - Not too urgent to check it out - just wanted to get the latest changes in - It seems Tesla changed how they report sleep and this addresses this and some other fixes 

The one in the non-production store will not install for me there is an Activate button under purchase but when I click  the button nothing happens. Maybe someone else can see if they can install it?

Link to comment
This topic is now closed to further replies.

  • Create New...