Jump to content

Admin Console Wont Load


ulrick65

Recommended Posts

Long time user, been a while since I logged in to the console, about 3 months or so.  Just bought an EISY to upgrade my  ISY994i 1024 IR

Currently running on 5.3.0 so figure I have to update that, then take fresh backup.  Everything on ISY is working fine.  Shows green in the portal, I can ping it just fine, I can download the admin.jnlp fine from it, I can connect to it via it's web address and control it there, Alexa voice commands all work fine too.

I tried clearing the java cache, all other recommendation over the year on it.  I uninstalled Java completed.  Deleted the cache folder, rebooted computer more times than I can count, etc.

Running admin.jnlp does nothing.  I can see the java tasks running in Task Manager (one Web Launcher and one Web Start Launcher), but I never get anything on the screen.  If I run it again, I simply get another process in Task Manager.  I never get the finder screen at all.

I have had in the past after upgrades and such where it can not find ISY once the launcher loads...but I have never seen it where I never get the launcher in the first place.

I tried download admin.jnlp from both my ISY and the website...both do exactly the same thing.  Have completely uninstalled Java multiple times.  Other Java test as pass with no issues...only one version of java running, all good.

Is it possible that ISY is not compatible with the latest Java version or something?  I am running Version 8, Update 381 (build 1.8.0_381-b09)

This has been killing me...today was supposed to be upgrade day to EISY and it turned out spending hours and hours trying to connect ISY994 that I have been using for 15 years through all the versions and never had an issue connecting like this.

Any help or pointers would be much appreciated.

I have a backup of the ISY to load to EISY but from what I understand, I can not migrate with the 5.3.0 firmware loaded?

Thanks.

 

Link to comment

@ulrick65

Clear your java cache, including checking the box "installed applications, then download the IoX Launcher, from the link below, which will put a shortcut on your desktop.

https://isy.universal-devices.com/start.jnlp

You'll also need to update your ISY to 5.3.4 (assuming that you're not using the Zwave 300 card) prior to migrating to the eisy.  Be sure to carefully read the ISY to EISY migration instructions before trying to migrate.

Any time you update the ISY or EISY firmware you'll need to clear your java cache and reinstall the IoX Launcher

You also need to update your eisy firmware prior to migration. This may take a while so be patient.

Let me know if this resolves your issues.

Edited by Techman
Link to comment
Just now, Techman said:

@ulrick65

Clear your java cache, including checking the box "installed applications, then download the IoX Launcher which will put a shortcut on your desktop.

https://isy.universal-devices.com/start.jnlp

You'll also need to update your ISY to 5.3.4 (assuming that you're not using the Zwave 300 card) prior to migrating to the eisy.  Be sure to carefully read the ISY to YISY migration instructions before trying to migrate.

Any time you update the ISY or EISY firmware you'll need to clear your java cache and reinstall the IoX Launcher

You also need to update your eisy firmware prior to migration. This may take a while so be patient.

Let me know if this resolves your issues.

Thanks for the reply.  Note my post...I have cleared the cache, including applications, many times.  I have completely uninstalled Java and deleted the folders associated with it.  Rebooted, then reinstalled.  Etc. etc.
 

I can download the start.jnlp file, but it does nothing either...no icon on the desktop.  The admin.jnlp file, same thing.  Runs...but nothing happens.

Thanks.

Link to comment
1 hour ago, ulrick65 said:

I can see the java tasks running in Task Manager (one Web Launcher and one Web Start Launcher), but I never get anything on the screen.

If you're seeing something like this:

image.png

 

You might need to delete the UD*.state files. First, stop all Java Web Launcher processes (i.e. make sure nothing showing IoX Finder or Universal Devices Administrative Console are active).

https://wiki.universal-devices.com/index.php?title=Main_Page#Admin_Console_Minimized/Invisible_and_Cannot_be_Restored

If there's not multiple .state files in your folder it might be worth performing a search for UD*.state on the root directory and/or making sure hidden files are shown (though these typically aren't hidden, but you never know). 

You keep mentioning "admin.jnlp". If downloading directly from the ISY that's fine, but please make sure you delete all OLD copies of that file anywhere on your computer. For the last five years IoX Launcher (formerly ISY Launcher) has been the suggested method to access the admin console. IoX Launcher is the process @Techman links to above "start.jnlp". 

Link to comment
1 hour ago, Techman said:

Are you on a Windows or MAC, and what version?

You might have to disable firewall software before installing IoX Launcher.

The java you have installed is correct. 

Thanks for the reply. I am on Windows 10.  It is not a firewall issue...I have full open access between this computer and the ISY.  I can ping it, download the file from it, connect to via the web address directly and hit it via telnet on port 22.

 

 

36 minutes ago, Geddy said:

If you're seeing something like this:

image.png

 

You might need to delete the UD*.state files. First, stop all Java Web Launcher processes (i.e. make sure nothing showing IoX Finder or Universal Devices Administrative Console are active).

https://wiki.universal-devices.com/index.php?title=Main_Page#Admin_Console_Minimized/Invisible_and_Cannot_be_Restored

If there's not multiple .state files in your folder it might be worth performing a search for UD*.state on the root directory and/or making sure hidden files are shown (though these typically aren't hidden, but you never know). 

You keep mentioning "admin.jnlp". If downloading directly from the ISY that's fine, but please make sure you delete all OLD copies of that file anywhere on your computer. For the last five years IoX Launcher (formerly ISY Launcher) has been the suggested method to access the admin console. IoX Launcher is the process @Techman links to above "start.jnlp". 

 

Thanks for the info...I have deleted the .state files and also search the entire computer for them.  None on the entire system.

The reason I mention Admin, is that is the file that seems to download from the web in some of the links around getting this think to work, etc.  It is also the file that downloads from the ISY itself to run to connect.  I was not sure (it has been a while) which one to start with.  My shortcut that I had saved pointed to the start.jnlp file...but many of the other things I was reading was pointing to the admin.jnlp file directly...so I have tried both.  In all case, I only have one version of either file on the system at the time.  I tried both off the ISY itself (same one as provided above by @Techman).  No joy in any way shape or form.  That's why I wondered about the version of Java...it's the only thing I can think of that has changed.

I am going to try another computer tomorrow or when I can get back to it and see what I find out.

Thanks.

Link to comment

Just used my laptop quick to see if it would work...works like a charm.

At least I know it is related to my primary desktop I guess.  I will try one more time to do a complete removal and reinstall.

If anyone has any other ideas, please let me know.

Thanks for the help.

  • Like 1
Link to comment

Reboot your computer, then clear the java cache and download the IoX Launcher (again)

I think you had multiple versions of launcher programs running at the same time. You should only have the java Web Launcher running in the windows task manager.  Web start launcher shouldn't be running.

Link to comment
7 minutes ago, Techman said:

Reboot your computer, then clear the java cache and download the IoX Launcher (again)

I think you had multiple versions of launcher programs running at the same time. You should only have the java Web Launcher running in the windows task manager.  Web start launcher shouldn't be running.

Did that twice before...but will try again likely tomorrow.  I got it working on my laptop, so I am going to backup and upgrade the firmware there while I can, and then back another backup so I can migrate over to EISY.

I do see that there are two instances of the Web Launcher running on my laptop now, but none of the Web Start Launcher...so you definitely could be onto something.

I will see how it goes and post back.

Thanks again for the help.

Link to comment
2 hours ago, ulrick65 said:

Did that twice before...but will try again likely tomorrow.  I got it working on my laptop, so I am going to backup and upgrade the firmware there while I can, and then back another backup so I can migrate over to EISY.

I do see that there are two instances of the Web Launcher running on my laptop now, but none of the Web Start Launcher...so you definitely could be onto something.

I will see how it goes and post back.

Thanks again for the help.

If you still have an issue after trying all of the above, then work through this list:

1. Java applications are blocked by your security settings

Close all your browsers

Go to System Preferences | Java to get to Java Control Panel

Click on Delete Files and make sure you check Applications

Click on the Settings Button

Make sure Keep temporary files on my computer is checked

Click on the Security tab on the top

Click on Restore Security Prompts and then click on Restore All button on the ensuing dialog

Click on the Edit Site List

Click on the Add button

Enter https://isy.universal-devices.com followed by hitting the Return key on the keyboard. Accept the warning

Click on the OK button

2. Resource cannot be downloaded (admin.jnlp)

99.9% of the cases, this is due to the installation of the following software:

Relevant Knowledge

Qustodio

3. admin.jnlp does not start the Admin Console

If Java is indeed installed, the reason is that .jnlp file association is broken (it has to point to javaws.exe). Search for javaws.exe in the computer. Right mouse click and select "Open with" and point to "javaws.exe" to fix the .jnlp file association.

Cannot find Valid Java Home

This issue usually happens on Windows and when you have had multiple versions of Java installed especially the older version. What you need to do:

 

Clear your java cache

Uninstall all versions of Java using the Control Panel | Add/Remove Programs

Delete these directories (if they exist):

C:\Program Files\Java

C:\Program Files\Oracle

C:\Program Files(x86)\Java

C:\Program Files(x86)\Oracle

C:\Program Files (x86)\Common Files\Java

C:\Program Files (x86)\Common Files\Oracle

Delete the following directories (if the exist):

Open file explorer and click in the tree to reach c:\users\<username>\AppData\

Search for "java" (note: other windows settings and preferences for your user determine where "Java" folders get created. (generally they appear under "sun" and "oracle" folders.)

Open Search or click "Windows/Start" button:

In the search box, type Environment and choose Edit the System environment Variables

Click Environment Variables

Under User variables for <username>

Click on the Path | Edit and then delete all occurrences of Java and Oracle

If you see JAVA_PATH, click on it and then click the Delete button

Under System variables

Click on the Path | Edit and then delete all occurrences of Java and Oracle

If you see JAVA_PATH, click on it and then click the Delete button

Click the OK button (3 times to get out of "System Properties")

Reboot your computer

Reinstall Java 64bit version

If you were running the 32bit (x86) version of Java you might need these additional steps after reinstalling Java 64bit version:

 

Open Search or click "Windows/Start" button:

In the search box, type Environment and choose Edit the System environment Variables

Click Environment Variables

Under "System variables" Click "New..."

For "Variable name:" type JAVA_HOME

(ALL CAPS)

For "Variable value:" enter the directory for your new Java install

Example: C:\Program Files\Java\jre-#.#

[NOTE: #'s will be current version just installed]

You can click "Browse Directory.." to find the directory or type or paste it in the entry field.

Click OK

Find "PATH" (still under System Variables)

Click "Edit..."

Click "New"

Enter: %JAVA_HOME%\bin

Pay attention to CAPS

Click "OK" (total of 3 times to exit "System Properties"

Reboot your computer

To confirm Java is on the system start Command Prompt or PowerShell and type java -version. You should get a result similar to:

java version "1.8.0_371"

Java(TM) SE Runtime Environment (build 1.8.0_371-b11)

Java HotSpot(TM) 64-Bit Server VM (build 25.371-b11, mixed mode)

IoX Launcher should be able to launch correctly every time now. If you still have issues please file a support ticket.

Windows should update these entries as Java updates, but should you have issues you might need to update the JAVA_HOME directory above.

 

  • Like 1
Link to comment
19 hours ago, ulrick65 said:

Just used my laptop quick to see if it would work...works like a charm.

At least I know it is related to my primary desktop I guess.  I will try one more time to do a complete removal and reinstall.

If anyone has any other ideas, please let me know.

Thanks for the help.

Go to the Java Control Panel (located in the Windows Control Panel) and compare the Security and Advanced tab settings between your laptop and desktop.

Link to comment
On 8/13/2023 at 9:35 PM, DennisC said:

If you still have an issue after trying all of the above, then work through this list:

1. Java applications are blocked by your security settings

Close all your browsers

Go to System Preferences | Java to get to Java Control Panel

Click on Delete Files and make sure you check Applications

Click on the Settings Button

Make sure Keep temporary files on my computer is checked

Click on the Security tab on the top

Click on Restore Security Prompts and then click on Restore All button on the ensuing dialog

Click on the Edit Site List

Click on the Add button

Enter https://isy.universal-devices.com followed by hitting the Return key on the keyboard. Accept the warning

Click on the OK button

2. Resource cannot be downloaded (admin.jnlp)

99.9% of the cases, this is due to the installation of the following software:

Relevant Knowledge

Qustodio

3. admin.jnlp does not start the Admin Console

If Java is indeed installed, the reason is that .jnlp file association is broken (it has to point to javaws.exe). Search for javaws.exe in the computer. Right mouse click and select "Open with" and point to "javaws.exe" to fix the .jnlp file association.

Cannot find Valid Java Home

This issue usually happens on Windows and when you have had multiple versions of Java installed especially the older version. What you need to do:

 

Clear your java cache

Uninstall all versions of Java using the Control Panel | Add/Remove Programs

Delete these directories (if they exist):

C:\Program Files\Java

C:\Program Files\Oracle

C:\Program Files(x86)\Java

C:\Program Files(x86)\Oracle

C:\Program Files (x86)\Common Files\Java

C:\Program Files (x86)\Common Files\Oracle

Delete the following directories (if the exist):

Open file explorer and click in the tree to reach c:\users\<username>\AppData\

Search for "java" (note: other windows settings and preferences for your user determine where "Java" folders get created. (generally they appear under "sun" and "oracle" folders.)

Open Search or click "Windows/Start" button:

In the search box, type Environment and choose Edit the System environment Variables

Click Environment Variables

Under User variables for <username>

Click on the Path | Edit and then delete all occurrences of Java and Oracle

If you see JAVA_PATH, click on it and then click the Delete button

Under System variables

Click on the Path | Edit and then delete all occurrences of Java and Oracle

If you see JAVA_PATH, click on it and then click the Delete button

Click the OK button (3 times to get out of "System Properties")

Reboot your computer

Reinstall Java 64bit version

If you were running the 32bit (x86) version of Java you might need these additional steps after reinstalling Java 64bit version:

 

Open Search or click "Windows/Start" button:

In the search box, type Environment and choose Edit the System environment Variables

Click Environment Variables

Under "System variables" Click "New..."

For "Variable name:" type JAVA_HOME

(ALL CAPS)

For "Variable value:" enter the directory for your new Java install

Example: C:\Program Files\Java\jre-#.#

[NOTE: #'s will be current version just installed]

You can click "Browse Directory.." to find the directory or type or paste it in the entry field.

Click OK

Find "PATH" (still under System Variables)

Click "Edit..."

Click "New"

Enter: %JAVA_HOME%\bin

Pay attention to CAPS

Click "OK" (total of 3 times to exit "System Properties"

Reboot your computer

To confirm Java is on the system start Command Prompt or PowerShell and type java -version. You should get a result similar to:

java version "1.8.0_371"

Java(TM) SE Runtime Environment (build 1.8.0_371-b11)

Java HotSpot(TM) 64-Bit Server VM (build 25.371-b11, mixed mode)

IoX Launcher should be able to launch correctly every time now. If you still have issues please file a support ticket.

Windows should update these entries as Java updates, but should you have issues you might need to update the JAVA_HOME directory above.

 

 

Thanks for that detailed post!  Awesome list!

I got it working...by doing an uninstall again and removing all folders (as shown above) though most of them were already gone after the uninstall.  Then a reboot, verify everything is gone and then reinstall JAVA and the launcher now works.

I can't get the EISY to show up in the launcher...but I will figure that out, I have not had time to mess with it much yet.  Got my old ISY to show up there though and it is working fine.

Thanks for all the help everyone, I appreciate it.

 

  • Like 1
Link to comment
On 8/14/2023 at 2:26 PM, gzahar said:

Go to the Java Control Panel (located in the Windows Control Panel) and compare the Security and Advanced tab settings between your laptop and desktop.

Good advice...I got it working before seeing this.

I am still not sure what the issue was...I am not a big fan of just saying it was a "glitch", I prefer to find root cause.  But in this case, I may have to just call it that.

Thanks.

Link to comment
3 hours ago, ulrick65 said:

I can't get the EISY to show up in the launcher...but I will figure that out

Glad you got it working! Seems like could have been a corrupt Java install since removing it and all directories helped resolve the issue. 

As for the eisy not showing up it could be your network not allowing it to announce itself correctly. Once you add it though you should save the list in an easy place should you need to load it later. With the ISY Finder window populated with the eisy (and your ISY994 while it's active) just click "SAVE" and it will offer a file name like "ISY-Finder.Wed 2023.08.16 04.30.36 PM.state". Save that locally in a quick and easy to access directory. Then if the entries go away you can hit "LOAD" and find that .state file and it will get you back in business.

When adding manually try to add:

  • https://###.###.###.###:8443/desc       <-- change all the # to your IP address for the eisy. 
  • https:// eisy.local:8443 /desc       <-- remove the spaces I added

(https://wiki.universal-devices.com/index.php?title=Eisy:User_Guide#Can't_Find_eisy)

 

Also, make sure that you set an IP reservation in your router for the eisy so it's not always changing IP address on you. My router usually has no problem with the IP address being found for the eisy, but is slow to resolve the eisy.local address. The ISY994 was able to set a static on the device, but that created a lot of issues for casual users over the years that UDI removed that ability in the Polisy and eisy so IP Reservations are the only way to keep it from getting a different IP when the network lease for IPs expires or network restarts. 

  • Like 1
Link to comment
1 hour ago, Geddy said:

Glad you got it working! Seems like could have been a corrupt Java install since removing it and all directories helped resolve the issue. 

As for the eisy not showing up it could be your network not allowing it to announce itself correctly. Once you add it though you should save the list in an easy place should you need to load it later. With the ISY Finder window populated with the eisy (and your ISY994 while it's active) just click "SAVE" and it will offer a file name like "ISY-Finder.Wed 2023.08.16 04.30.36 PM.state". Save that locally in a quick and easy to access directory. Then if the entries go away you can hit "LOAD" and find that .state file and it will get you back in business.

When adding manually try to add:

  • https://###.###.###.###:8443/desc       <-- change all the # to your IP address for the eisy. 
  • https:// eisy.local:8443 /desc       <-- remove the spaces I added

(https://wiki.universal-devices.com/index.php?title=Eisy:User_Guide#Can't_Find_eisy)

 

Also, make sure that you set an IP reservation in your router for the eisy so it's not always changing IP address on you. My router usually has no problem with the IP address being found for the eisy, but is slow to resolve the eisy.local address. The ISY994 was able to set a static on the device, but that created a lot of issues for casual users over the years that UDI removed that ability in the Polisy and eisy so IP Reservations are the only way to keep it from getting a different IP when the network lease for IPs expires or network restarts. 

Thanks Geddy...I got it working.  When I add something to the finder, I have to leave off the desc at the end, or it wont find it.  Just the IP and PORT are enough.  Was that way with the ISY was well.

 

Link to comment
Guest
This topic is now closed to further replies.

×
×
  • Create New...