September 28Sep 28 I tried to open the admin console from my Mac and it had disappeared from my menu. I have continued to try using online instructions. Have I failed to pay some fee? If so, to whm and how?
September 28Sep 28 See https://wiki.universal-devices.com/Main_Page#On_Big_Sur,_Admin_Console_is_no_longer_a_separate_Window
September 28Sep 28 3 hours ago, hart2hart said:That’s likely a macOS issue. Apple removed support for Java recently.It is near certainty that it is a Mac issue. I lost mine a month or so ago. As far as I know, one must now use the eisy-ui. Edited September 28Sep 28 by oberkc
September 28Sep 28 My brother was having problems with the AC on his Mac, I suggest updating to get eisyUI.In short the update failed, eisyUI won't start and no signs of a web server. SSH does work fortunately.He has submitted a ticket, awaiting response.
September 28Sep 28 Java 8 continues to work fine on the latest macOS Golden Gate on Apple Silicon (M series).Uninstall any existing version of Java and download the latest Java for macOS Arm64 from herehttps://www.java.com/en/download/manual.jsp Edited September 28Sep 28 by Diesel
Thursday at 10:51 AM3 days I saw the comment about Network Resources coming soon, thanks. But what is the plan for Web Server file transfers. Thanks
Friday at 11:28 AM2 days NR is already implemented, although requires fixes, in the next release.Web Server is legacy, and using default conflicts with eisy-ui. We had not planned on migrating this feature, files can still be added via ssh.What is the use case?
Friday at 06:58 PM2 days @Javi My non-standard undocumented node server built in 2016 is a cllent of an eternal web server on a raspberry pi. I believe this is working as of now, based on http return codes I have looked at. If this is going away I can probably substitute REST commands and network resources but it would be good to know. It's a nice feature to have.
Friday at 08:02 PM2 days 1 hour ago, stillwater said:@Javi My non-standard undocumented node server built in 2016 is a cllent of an eternal web server on a raspberry pi. I believe this is working as of now, based on http return codes I have looked at. If this is going away I can probably substitute REST commands and network resources but it would be good to know. It's a nice feature to have.Are you sure this is the same Web Server? Admin Console > Configuration > Networking > Web Server
Friday at 09:43 PM2 days @Javi You are right, it's very different. There is an external web service that is consumed as a client by IoX. Configured (host name = ip address and user/ password/Port) via AC>Plugins>Plugin Configuration. I am pretty sure these parameters can be entered via REST also.
Yesterday at 06:59 PM1 day I have a whole dashboard that is hosted on the web server. I needed to host it there to avoid cross domain scripting errors. I don't mind if it moves to another port, but I would really like it to remain viable. http://192.168.3.14:8080/USER/WEB/HV2.htm# Edited yesterday at 07:00 PM1 day by Andy P
4 hours ago4 hr I tried to access the files by SSH which I think are in the /var/isy/files/user/web directory but I got stopped with permission errors at the /isy directory level.So if there is not going to be an option to manage the user/web files in eisy-ui, how are they accessed using ssh?
4 hours ago4 hr 7 minutes ago, Andy P said:I tried to access the files by SSH which I think are in the /var/isy/files/user/web directory but I got stopped with permission errors at the /isy directory level.So if there is not going to be an option to manage the user/web files in eisy-ui, how are they accessed using ssh?Start by doing: sudo sh and enter the admin password. This puts you in superuser mode, and can go anywhere.
Create an account or sign in to comment