Jump to content

Using ISY-99i to Notify via Email and Text


hyounker

Recommended Posts

Can anyone point me in the right direction for some documentation on this matter? I've searched around, but cannot find anything helpful.

 

Also, are there any minimum requirements within the ISY?

 

FYI, here's my project. I came home from an extended holiday vacation to find several hundred dollars worth of frozen food thawed and rotting in our large freezer. I'd like to set up a circuit that will email and text me when the temp in our freezer reaches a certain point, in the event of another failure. I have access to a thermocouple and a PID temp controller that will close and/or open contacts when the temperature reaches a predetermined threshold. I'm thinking of connecting the PID to an I/OLinc that will in turn trigger email and text notifications from the ISY. I'm sure I'll need some sort of delay to prevent emails and texts everytime we open the door.

 

I have an ISY-99i currently.

 

Thanks,

 

hyounker

Link to comment

Hi,

 

You have to setup the ISY to send an email notification

see http://wiki.universal-devices.com/index.php?title=ISY-99i/ISY-26_INSTEON:Messaging_Configuration

 

then once the notification is setup (and tested)

you create a program that triggers on your temp sensor.

The forums have lots of examples such as...

http://forum.universal-devices.com/viewtopic.php?f=26&t=10413&p=79120&hilit=program+send+email#p79120

 

pretty much any status or event happening that the ISY sees can trigger an email.

You can have many different notification/messages setup and then the ISY program sends the appropriate one.

Link to comment

Thank you, tgutwin.

 

I didn't get very far! I copied my smtp server settings directly from Outlook, which I use successfully everyday. Our smtp server is as follows:

 

smthauth.earthlink.net

Port 587

 

I have double and triple checked the username and password. I have also increased the timeout to 10,000, incrementally, to no avail.

 

I continue to get the same error when I test:

 

Mail Server Failure [from timed out]

 

I get the same error when I check the "default" box and test.

 

I've turned Windows Firewall off, but get the same error.

 

I have been very careful to hit the "Save" button after changes.

 

Can anyone help?

 

Thanks,

 

hyounker

Link to comment

I don't use Outlook, so with that in mind; here is my guess...

 

Is your smtp server expecting TLS or some other type of encryption like SSL?

Check what your smtp server is expecting.

 

I have to add SSL encryption to all my mail using a an open tool called Stunnel (http://www.stunnel.org)

(i believe there is a version that runs as a service on M$)

Its easy to setup and it acts like a proxy: you point ISY at your locally running stunnel and it proxies all the data (ssl encrypted) to the mail server.

 

 

tom

Link to comment

hyounker-

 

Several things to check and try:

 

1) Very important! Neither the Subject or Body of an outbound message can be blank or the message WILL fail.

 

2) If your DNS is not working, the SMTP server cannot be found. Try configuring theISY to use 8.8.8.8 for a NS server. This does require setting static addressing for the ISY. Make sure you choose an address that is OUTSIDE of your router's DHCP pool.

 

Check your error log immediately after testing and post any errors from the right time frame.

 

-Xathros

Link to comment

Thanks for the reply.

 

I cannot get past the "Test", so I'm not even sure how to put something in the Subject or Body yet.

 

I am using the same DNS server on the ISY as my laptop and other static IP devices in my house (including a home server) and I am not having any trouble negotiating to any websites or the smtp server in Outlook.

 

Just minutes ago, using the default, the "Test" fails. Here's the only thing in the error log with today's date:

Mon 2013/01/28 04:36:37 PM System -5012 81

 

After opening the admin console, the first time I hit the "Test" button, I get these errors:

 

Subscriber didn't reply to event:1 [26]

 

Mail server failure [to timed out]

 

Subsequent attempts to test, result in just the second "mail server" error.

 

My ISY is setup with IP address 192.168.1.99

My router is 192.168.1.1

My DHCP range is 192.168.1.101 - 192.168.1.150

My DNS server setting is 4.2.2.2

I have also tried 8.8.8.8, 68.94.156.1, and 68.94.157.1. The latter are ISP provided.

The router is a WRT54GL with DD-WRT installed.

 

Any help appreciated.

 

hyounker

Link to comment

Michel-

 

That router config should not care. DD-WRT on the WRT54GL is a rock solid router. Never had an issue with that and the ISY. That said, there may be some restrictions somewhere deeper in the router that are causing trouble.

 

hyounker-

 

Your ISY's IP and DNS settings look perfect to me.

 

First, on the DD-WRT Setup tab, uncheck all three of:

Use DNSMasq for DHCP

Use DNSMasq for DNS

DHCP-Authoritative

 

Then, make sure that the ISY's mac and IP addresses are not on a filter list on the Access Restrictions tab. There are multiple lists so check them all.

 

Test again, post results.

 

-Xathros

Link to comment

Sorry Guys, I'm still having trouble.

 

I set the ISY to DHCP, but still could not get the "Default" settings or my known good settings to pass the email test.

 

Also, I unchecked the 3 boxes as Xathros advised. I also checked the Access Restrictions tab. I only have one access restriction (keeping my kids off Facebook on my laptop!). I even disabled it and nothing changed. Same errors.

 

Someone sent me a PM asking if I had enabled internet access. When I click on "Enable Internet Access", I get the following error:

 

"Failed Enabling Internet Access"

 

Any other ideas?

 

Thanks for all the help.

 

hyounker

Link to comment
Thank you, tgutwin.

 

I didn't get very far! I copied my smtp server settings directly from Outlook, which I use successfully everyday. Our smtp server is as follows:

 

smthauth.earthlink.net

Port 587

 

I have double and triple checked the username and password. I have also increased the timeout to 10,000, incrementally, to no avail.

 

I continue to get the same error when I test:

 

Mail Server Failure [from timed out]

 

I get the same error when I check the "default" box and test.

 

I've turned Windows Firewall off, but get the same error.

 

I have been very careful to hit the "Save" button after changes.

 

Can anyone help?

 

Thanks,

 

hyounker

 

It looks like you have the servername wrong...

smtpauth.earthlink.net

___^___

Again please have a second set of eyes look at your servername (ping it too)

and your username

 

 

Here is a snippet google found

Please ensure you are using the following settings:

 

Incoming Server (POP3 server): pop.earthlink.net

POP3 port: 110

 

Outgoing Server (SMTP server): smtpauth.earthlink.net

SMTP port: 587

 

Select "Use name and password"

username: full email address (user@earthlink.net)

Select "Use secure authentication"

secure connection: 'TLS, if available' or no. Both should work.

Link to comment

tgutwin,

 

That was a fat finger mistake. I set up email accounts constantly and am very confident with the smtp server for my email account. Unfortunately, that's one of my many hats at work!!

 

However, I have long since abandoned my particular account settings in hopes that the default will eventually work. Once I get the default to work, I'll move onto my "real" email account settings.

 

Your google snippet is accurate, other than the pop server. I actually use our company domain incoming mail server.

 

Thanks,

 

hyounker

Link to comment

hyounker-

 

Can you double check the gateway address in the isy and make sure it is correct.

 

On the DD-WRT Status, LAN tab, do you see the ISY's address listed and if DHCP'd, do you see it in the DHCP client list ?

 

I looked up the -5012 error and it indicates a UPNP subscriber problem. Do you have uPNP enabled or disabled on your router? (NAT/QOS, UPNP Tab) Mine is disabled.

 

-Xathros

Link to comment

Xathros,

 

I am currently in DHCP, so there is no gateway setting on the ISY.

 

In the router, I see the ISY's leased address, 192.168.1.104, in both the Active Client list and the DHCP list. I also noticed that the Active Client list refreshes itself every so often, dropping a few IP addresses (including the ISY), then replacing them. I am assuming this is normal.

 

Do you know what versions of DD-WRT that you've had success with in the past?

 

Can you confirm that using the "Default" settings in the ISY for setting up notifications is reliable?

 

Thanks again for the help.

 

H

Link to comment

hyounker-

 

When I was on the WRT54GL (replaced 4 months ago) it was running v24 Sp-2 (VPN). I am currently running on the DD-WRT x86 v24 Sp1. Neither have had any issues with the ISY. I used v23 a while back on the 54GL with my ISY 99i and that worked as well.

 

Next thing to look at is the security tab in the router. Disable the SPI firewall and uncheck any filters. Test again.

 

And yes, when I test the default ISY mail server settings do work just fine. Are you getting NTP time/date updates at the ISY or is there a red ! in front of the time server field?

 

-Xathros

Link to comment
  • 4 weeks later...

My apologies to everyone. I started out on vacation, but had to return early due to my son's health. He mysteriously developed a spleen laceration while the wife and I were in Vegas. Of course!!! The timing of a 16 year old!!! All's well now, so I am hoping to resolve this email issue.

 

Thanks to everyone for helping. I went back and reviewed the previous posts and tried all the suggestions again. The only thing I did not answer was a question from Xathros. My UPNP setting in my router is set to "Disabled". Also, in your last post, you asked me to try some other things. I disabled the SPI firewall and no filters were checked. Retrying resulted in the same timeout error. I do not have a red exclamation mark in the time server area.

 

Again, I have abandoned my custom email settings until I get the default settings to pass the test.

 

I have all the hardware in place for my freezer monitoring project (see my first post in this thread). I just need to get my ISY sending emails.

 

Thanks again for all the help,

 

hyounker

Link to comment

hyounker, Michel-

 

If after the support session, the DD-WRT router still appears to be at fault, try this:

 

Log into the router, go to the Administration tab and make a backup of the router. Save the nvram.bin file where you can find it again in a few minutes. After the backup, also from the administration tab, reset the router to factory defaults. Power cycle the router. Log back into the router (default user/pass is either root/admin or admin/admin), go to Administration and restore your backup. Power cycle the router again and restest.

 

-Xathros

Link to comment
  • 2 weeks later...

Just finished a 2 minute support session with Darrell from Universal Devices and he fixed my problem instantly. My problem was that I did not have any "Recipients" under the Settings/Groups tab. After reviewing the documentation here:

 

http://wiki.universal-devices.com/index ... figuration

 

the problem is clear. The first step in the "Messaging Configuration" is "SMTP Configuration". AFTER the SMTP Configuration, is a detailed explanation of entering "Recipients". I never got past the "SMTP Configuration", so I never got to "Recipients".

 

Being a newcomer to the ISY, I was driving in the dark with this setup information. I had no idea that the test was going to generate a test email. I guess I was assuming that the ISY was verifying that it could connect with the SMTP server and would deliver a "Pass" message on the screen, as it did so quickly for a "Fail".

 

Some obvious suggestions would be to make a documentation change in the SMTP Configuration page that would warn that the test button would generate a test email (instead of a "notification" which is only ISY speak, not real world speak) and will not work unless a Recipient is entered under "Groups" (which is also a strange name from a beginners standpoint). A page that would spell out the requirements for a test email would also help to clear this up. The button could also be labeled better. For instance, "Send Test Email", would be a much better label than "Test".

 

Thanks to all for the help. I learned a few other things along the way and am hopeful that some other newbies will find this string and get through this problem a little quicker than I did.

 

hyounker

Link to comment
  • 2 weeks later...

Archived

This topic is now archived and is closed to further replies.


×
×
  • Create New...