Jump to content

Unable to launch application issue


DIggerNSE

Recommended Posts

I have been running my system now for about 6 weeks.. basically with few problems.. however this morning I cannot log into admin consol. I get a pop up "Unable to launch the application." When i click on details of window, another window say: Error: The application has requested a version of the JRE (version 1.6+) that is not installed. I am on a imac os 10.6.8 with all the software up to date according to "software updates"

 

ISY994i/IR Pro Any suggestions ....Thank you

Link to comment

I'm on a mac (osx 10.6.8) and have the identical problem. I can see the html interface screen that has the ribbon, [home] (page 13 of the user guide) but when I click on the admin console button it takes me to the "keep this window open" screen and a note pops up that says "Inactive Plug-in". clicking on that takes me to the software update window that eventually reports all my software is up to date. I checked my java plug in. its active and at version 1.6.0_37.

 

Help, it was working awhile ago but now I'm locked out!!!

Link to comment

apple forums are buzzing with the problem. check this link.

 

https://discussions.apple.com/thread/47 ... 0&tstart=0

 

in essence, apple disabled all java yesterday due to some horrific security breach. apple used their xProtect.meta.plist behind the scenes nuke method. This disables java across all browsers on the affected mac. it is relatively easy to re-enable java in osx 10.6 but you have to rewrite a few plist keys. the method is found on the second page of the thread I linked to above. the following is an excerpt of a post from Shirkan79

===================

in terminal, type the following commands to update the plist keys:

 

sudo defaults write /System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/XProtect.meta.plist JavaWebComponentVersionMinimum "1.6.0_37-b06-434"

 

and if you don't want apple to update the plist (in this example until 30 Jan 2014)

open terminal or use the current open one and run

 

sudo defaults write /System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/XProtect.meta.plist LastModification "Thu, 30 Jan 2014 00:00:01 GMT"

====================

 

the rumor is apple will release a patch/update shortly. perhaps shoehorn java 7 onto osx 10.6.8 which apparently was something they weren't planning to do. The real issue is why did they disable the ability to run the local copy of previously registered java apps? pretty much defeats the purpose of registering and downloading local copies. Also, the forums indicate that apple is moving away from "apple" java support and will require users to suffer through oracle's useless website for ongoing future support.

 

btw, this is another reminder why java sucks so bad.

Link to comment

apple just released release 12 of java 1.6. everything is working once again. just use the software update feature from mac os 10.6.8 to update the package. you don't need to do any of the plist manipulations mentioned previously.

 

I tested the 1.6 update with the administrative console and all is well for now.

 

There is the caveat that the magic mojo the programmers put into this release may prove insufficient to overcome the hackers mojo and apple may again nuke java access (at which point the plist key modification should restore functionality). the forums indicate that apple will indeed drop their support for java. this java release could be the last for os 10.6.8. time to think about 10.7 or 10.8.

Link to comment

man, all this to change a single digit in my isy program. it took a day but it its working again.

 

the gubbermint keeps saying the hackers have powerful mojo and are about to 9/11 the internet. hmm.... I'm thinking the days of internet dependent applications might need a revisit.

Link to comment

Hi robr,

 

Thanks again. Would you please let me know which URL you are using to access your ISY? The only issue I see is that we have defined 1.7+ as the minimum requirement in all URLs so I am not sure how yours is still working.

 

I am quite disappointed in both Apple and Oracle:

Apple for developing Java on its own and then forcing people to upgrade OSs to use certain Java levels. And, Oracle for not being security aware especially since Java runs on billions of devices.

 

Thanks again and with kind regards,

Michel

Link to comment

Repair work to Java is long overdue and Apple is using its blocked list to push Oracle into fixing these security bugs. A few weeks ago one was so serious that the Department of Homeland Security advised people to disable or remove Java.

 

Things are getting much better with two maintenance releases which address the problems. In both cases I learned of this before it had a chance to impact me so I had an idea of what was going on. Macrumors.com always seems to be up on these things before the rest of the media, so it's a good site to follow. Here is their article on the latest Java block and fix:

 

http://www.macrumors.com/2013/02/01/ora ... n-on-os-x/

Link to comment

hello...

 

i'm running OSX 10.6.8 on a mac pro and have done all of the updates including the latest one for java through the apple update service. i have enabled java in the java preferences as well as in my browsers (safari and firefox). when i go to this URL

 

http://www.universal-devices.com/99i/

 

the admin page comes up, an error box flashes, and no login window appears. i've tried this with both browsers.

 

what am i missing?

 

thanks,

ken

Link to comment
  • 1 year later...

Hi Ken,

 

Please either upgrade your OS to 10.7 OR use the following link instead:

http://isy.universal-devices.com/99i/3. ... min16.jnlp

 

With kind regards,

Michel

Does anyone know why this link might stop working?  I log into my system infrequently and tried this morning only to receive a 404 not found error.  My unit appears to be functioning normally.  Solid blue power light, no error light.  I rebooted it and that did not help.

 

I'm running 10.6.8 and using Safari or Firefox to connect.

 

Many thanks in advance

Link to comment

Archived

This topic is now archived and is closed to further replies.


×
×
  • Create New...