Jump to content

Google Home and UD unlinked and relinked but devices not updating


JSP0511

Recommended Posts

Hello all,

 

I have google home and the ISY linked through the ISY portal.  The issue I am running into is, when I add a new device to the ISY or for instance, create a new scene, I then add the device/scene to the ISY portal along with the spoken words but unlinking and relinking UD in google home does not refresh the devices.  This was not an issue months ago when I first linked everything together, at least if it was, it was not apparent to me.

 

I've unlinked and relinked numerous times.  I've unplugged my physical google home (the one in the living room).  Our bedroom Google home never worked with UD but I think I figured that issue out.

 

Do I need to reboot all Google Home devices?  Should I have to reboot them at all?

 

I'm scratching my head here.  It's as if the UD portion in my Google Home control is stuck in the past.

 

Thanks in advance for your assistance.

 

~Jerry

Link to comment

Another issue that I just came across. May be related. I added my wife's email in the portal as a user. I then tried to add UD in her google home account and received a notice that an error occurred. Her email was verified.

 

On the backend, maybe it is also not updating along with my devices.

 

 

Sent from my iPhone using Tapatalk

Link to comment

You don't need to add your wife's email in the portal. You just authorize with your email and password when linking in the home app. Also make sure your ISY is selected for your account.

 

Sent from my Pixel XL using Tapatalk

I was getting the same error. I assumed one log in per user with home. Saw that the portal allowed multiple users and thought that was the fix.

 

 

Sent from my iPhone using Tapatalk

Link to comment

After investigation, it appears that the device SYNC are working correctly. The device "living room" is not returned by the device SYNC.

 

I suspect that there may be 2 Google accounts involved, one for the initial SYNC, and a different one now.

 

I would recommend a factory reset of the Google Home.

 

A more detailed response should follow on the ticket.

 

Benoit

Link to comment

After investigation, it appears that the device SYNC are working correctly. The device "living room" is not returned by the device SYNC.

 

I suspect that there may be 2 Google accounts involved, one for the initial SYNC, and a different one now.

 

I would recommend a factory reset of the Google Home.

 

A more detailed response should follow on the ticket.

 

Benoit

Benoit,

 

I factory reset my living room home, logged back into everything but the old “living room lights” still appears in UD and not my newer “all living room lights”.

 

Also, when I ask google home to turn off or on living room lights or all living room lights home responds with “that device is not yet set up”. Home also states it does know which entrance light but I only have one.

 

When I ask for foyer light or kitchen, home responds the same way though I’ve never changed either function.

 

Home will turn my dining room lights and bathroom light on and off.

 

I cannot think of why some work and others do not. Most there devices were set up day one and never modified. I also can’t imagine why the device list in google home app will not update.

 

 

Should I completely remove my isy from the portal and start from scratch there?

 

 

 

Sent from my iPhone using Tapatalk

Link to comment

Benoit,

 

I factory reset my living room home, logged back into everything but the old “living room lights” still appears in UD and not my newer “all living room lights”.

 

Also, when I ask google home to turn off or on living room lights or all living room lights home responds with “that device is not yet set up”. Home also states it does know which entrance light but I only have one.

 

When I ask for foyer light or kitchen, home responds the same way though I’ve never changed either function.

 

Home will turn my dining room lights and bathroom light on and off.

 

I cannot think of why some work and others do not. Most there devices were set up day one and never modified. I also can’t imagine why the device list in google home app will not update.

 

 

Should I completely remove my isy from the portal and start from scratch there?

 

 

 

Sent from my iPhone using Tapatalk

Hi,
 
I looked at your ISY Portal spokens. 
 
I do see your "living room lights" under "ALL LR Lamps" ISY Scene, Could it be that you deleted the scene, but left the spoken in ISY Portal?
 
I don't see your "all living room lights" (Although there is one close, "living room lights")
 
There may be some devices with a room name GH may not like, if you are using rooms in GH. It may confuse a device with a room.
 
I don't think you need to reset everything. But I think it would help troubleshooting if you had less devices configured in ISY Portal.
 
Benoit
Link to comment

Hi,

 

I looked at your ISY Portal spokens.

 

I do see your "living room lights" under "ALL LR Lamps" ISY Scene, Could it be that you deleted the scene, but left the spoken in ISY Portal?

 

I don't see your "all living room lights" (Although there is one close, "living room lights")

 

There may be some devices with a room name GH may not like, if you are using rooms in GH. It may confuse a device with a room.

 

I don't think you need to reset everything. But I think it would help troubleshooting if you had less devices configured in ISY Portal.

 

Benoit

Benoit,

 

I originally had a lamplinc and an on/off module for two lamps in my LV. That was the “living room lights” spoken.

 

I then added a third lamp in my LV and deleted my original living room spoken, created a new scene which included all three lamps and add the spoken “living room lights” for scene All LV Lamps.

 

When I go to GH app, I see “living room lights” (the old scene with that spoken) which was deleted in the portal. The portal now has “all LV lamps” but GH app is not refreshing.

 

 

Sent from my iPhone using Tapatalk

Link to comment

Benoit,

 

I originally had a lamplinc and an on/off module for two lamps in my LV. That was the “living room lights” spoken.

 

I then added a third lamp in my LV and deleted my original living room spoken, created a new scene which included all three lamps and add the spoken “living room lights” for scene All LV Lamps.

 

When I go to GH app, I see “living room lights” (the old scene with that spoken) which was deleted in the portal. The portal now has “all LV lamps” but GH app is not refreshing.

 

 

Sent from my iPhone using Tapatalk

 

 

Currently, in ISY Portal, I'm seeing the following spoken "living room lights" with alternate spoken "living room", which is currently mapped to scene 50565.

I can see that this ISY scene was once named "All LR Lamps" but is now named "All Livingroom Lamps". That name does not really matter though. What matters is that the spoken "living room lights" is mapped to scene 50565.

 

In the device SYNC, I'm seeing that this is what is sent to Google Home.

 

Now, are you saying that "living room lights" in Google Home is not controlling scene 50565? What scene is it controlling?

 

Benoit

Link to comment

Currently, in ISY Portal, I'm seeing the following spoken "living room lights" with alternate spoken "living room", which is currently mapped to scene 50565.

I can see that this ISY scene was once named "All LR Lamps" but is now named "All Livingroom Lamps". That name does not really matter though. What matters is that the spoken "living room lights" is mapped to scene 50565.

 

In the device SYNC, I'm seeing that this is what is sent to Google Home.

 

Now, are you saying that "living room lights" in Google Home is not controlling scene 50565? What scene is it controlling?

 

Benoit

When I say turn on living room lights, home responds that the device is not yet set up.

 

Also in the gh app, when I go to home control, all lr lamps is not there. Living room lights is. This should be reversed since in portal, all lr lights exists. “Living room lights” does not. I’m speaking about the name of the device/scene.

 

 

Sent from my iPhone using Tapatalk

Link to comment

The name of the ISY scene that you see in ISY Portal is the one sent to GH. The ISY scene name is the one that you had for that scene when you added the spoken. It is not refreshed unless you delete the spoken and re-add it.

 

Now, I would try to change the spoken and see if GH understands it. The issue is that if you have a room named 'living room' enabled, then asking 'Alexa, turn on the living room lights' would be used to turn on all the lights in that room. I would bet that the room is enabled, with no devices in it.

 

Either way, please try a different spoken.

 

Thanks,

 

Benoit

 

 

Sent from my iPhone using Tapatalk

Link to comment

When I say turn on living room lights, home responds that the device is not yet set up.

 

Also in the gh app, when I go to home control, all lr lamps is not there. Living room lights is. This should be reversed since in portal, all lr lights exists. “Living room lights” does not. I’m speaking about the name of the device/scene.

 

 

Sent from my iPhone using Tapatalk

 

Benoit,

 

I went ahead and changed the spoken word to "workout room" and deleted "living room lights" from spoken word.  This worked when asking GH to turn on and off the lights but the UD service within GH app is still not updating.

 

Also,  I do use the assign room feature. Would this cause an issue?

 

Scene 50565 in the portal is mapped to "All Living Room Lights".  This scene did not exist back when I used "living room lights" as the scene and scene name as well as spoken word.  Now I have scene 50565 which is named "All Living Room Lights" with spoken word "living room lights".

 

I have since changed "workout room" spoken word back to "living room lights" and GH now turns the lights on and off perfectly but again, UD service within GH home does not show the correct devices.  IE: "all living room lights" does not appear.

 

QUESTION: Within UD in GH app, are the devices my spoken words?

Link to comment

Benoit,

 

I went ahead and changed the spoken word to "workout room" and deleted "living room lights" from spoken word.  This worked when asking GH to turn on and off the lights but the UD service within GH app is still not updating.

 

Also,  I do use the assign room feature. Would this cause an issue?

 

Scene 50565 in the portal is mapped to "All Living Room Lights".  This scene did not exist back when I used "living room lights" as the scene and scene name as well as spoken word.  Now I have scene 50565 which is named "All Living Room Lights" with spoken word "living room lights".

 

I have since changed "workout room" spoken word back to "living room lights" and GH now turns the lights on and off perfectly but again, UD service within GH home does not show the correct devices.  IE: "all living room lights" does not appear.

 

QUESTION: Within UD in GH app, are the devices my spoken words?

 

> QUESTION: Within UD in GH app, are the devices my spoken words?

In Google Home, all you will see is the spoken.

 

> Also,  I do use the assign room feature. Would this cause an issue?

 

It depends on your chosen device and room names.

If you have a room named "Living room" you can turn all the lights in that room by asking "Alexa, turn on the living room lights".

 

Now, what if you have a device named "living room lights"? I'm not sure what GH would do, but I'm guessing one would have precedence over the other.

Link to comment

> QUESTION: Within UD in GH app, are the devices my spoken words?

In Google Home, all you will see is the spoken.

 

> Also, I do use the assign room feature. Would this cause an issue?

 

It depends on your chosen device and room names.

If you have a room named "Living room" you can turn all the lights in that room by asking "Alexa, turn on the living room lights".

 

Now, what if you have a device named "living room lights"? I'm not sure what GH would do, but I'm guessing one would have precedence over the other.

Ok as of right now, I have no devices assigned to a room.

 

I will clean up my spokens and update if there is still an issue.

 

 

Sent from my iPhone using Tapatalk

Link to comment

Ok as of right now, I have no devices assigned to a room. 

 

I will clean up my spleens and update if there is still an issue. 

 

One last thing, when you update the portal and refresh, then refresh within gh app, how long does it take for gh to update its responses?

 

I only ask because I’ve replaced the work lamp with lights and gh still responds “turning off living room lamps” but the word lamps is no where to be found. Not in spoken or device names. 

 

Sent from my iPhone using Tapatalk

 

>One last thing, when you update the portal and refresh, then refresh within gh app, how long does it take for gh to update its responses?

 

 It's immediate.

 

>I only ask because I’ve replaced the work lamp with lights and gh still responds “turning off living room lamps” but the word lamps is no where to be found. Not in spoken or device names. 

 

You do have a "living room lamps". This is one of your alternate spokens for the scene 50565.

 

In ISY Portal, use the search. Type "living room lamp", and edit the entry.

 

Benoit

Link to comment

Archived

This topic is now archived and is closed to further replies.


×
×
  • Create New...