Jump to content

ISY on Polisy v5.3.0 (IoP) - OUTDATED


Michel Kohanim

Recommended Posts

OUTDATED - This version has been updated and is obsolete.
Please see the current release found in the Current Release area of the forums.

Fixes:


- Fixed status reporting of Z-Wave devices (such as motion sensors, etc.)
- Network Resources actions are queued when run from programs rather than run inline
- Fixed NLS strings for formatted values in ISY events for all node servers
- Fixed NLS strings for formatted values in ISY events for nodes using encoded editors
- Fixed XML crash when doing variable substitution in Network Resources
- IPv6 not allowing regular connection
- Invalid UUID sent to the portal 

Enhancements:

- Backup from 994 and Restore on Polisy!
WARNING:
- Everything is migrated except for Z-Wave
- If you're also changing PLMs, please make sure you also Restore the PLM
- Test binary network resources

Bugs:
- USB connected dongles (such as the PLM or Z-Wave Zooz Stick), cannot be unplugged and then plugged back in while ISY service is running. If, for any reason, you need to unplug, please use the Admin Console | Configuration tab | Reboot button to restart the service

How To Install:

- First, backup please!
- If on 5.2.0, Admin Console | Help | Automatically Upgrade. Once the Admin Console closes, wait 30 seconds before trying again. If Polisy does not show up in the ISY Launcher, please wait 60 seconds and reboot 
- Click the button on the front only once 
- Otherwise, ssh and do:
sudo pkg update && sudo pkg upgrade

How to use Z-Wave:

- Plugin your Zooz Stick in one of the USB ports on ISY
- Go to Admin Console | Configuration, check Z-Wave Support checkbox. Save and then click on the Reboot button  
- From that point, Z-Wave works as it does on the ISY-994 with the following exceptions
--- Backup/Restore of the Z-Wave dongle is not yet available
--- Z-Wave | Z-Wave Version is likely to be blank
- Note: for now, S2 is not yet supported 

 

With kind regards,
Michel

Link to comment
Share on other sites

1 minute ago, Michel Kohanim said:

@Bumbershoot,

It moves /FILES/CONF directory and backs it up somewhere. So, you will lose everything. That's why it's best to backup before you restore a 994 backup.

With kind regards,
Michel

In my case, losing every is just fine.   I assume that Z-Wave backup/restore is in the works?

Thanks again!

Link to comment
Share on other sites

I did the auto update and I got the admin console does not match the firmware error. Cleared Java files and downloaded the start.jnlp file again and retrieved the admin console directly from Polisy but it did not help. I also did sudo pkg update && sudo pkg upgrade and rebooted manually multiple times but can only access using the (cloud) option of the launcher.

The good news is my Z-Wave Sensative door and window strip is reporting properly now!

admin5.3local.png

Link to comment
Share on other sites

1 minute ago, upstatemike said:

So now it gets to the point to ask what ISY on Polisy can do that ISY994 plus Polisy cannot. What is my incentive to move anytime soon when a split system gives me some protection from having a single point of failure?

At the moment, and from functionality perspective, not much till your PLM dies. And, since I know you don't care about non-functional things such as security, I will not list them.

With kind regards,
Michel

Link to comment
Share on other sites

12 minutes ago, Michel Kohanim said:

At the moment, and from functionality perspective, not much till your PLM dies. And, since I know you don't care about non-functional things such as security, I will not list them.

With kind regards,
Michel

The only security standard I care about is NSTISSAM TEMPEST/1-92. Anything less than that is a waste of time.

Link to comment
Share on other sites

26 minutes ago, Michel Kohanim said:

You must use the ISY Launcher. If not, you need to clear cache and then use either:

https://<your polisy ip>:8443/admin.jnlp or 

https://isy.universald-devices.com/polisy/5.3.0/admin.jnlp 

 

I got the same mismatch between admin console version and firmware as @tazman when using:

     https://<your polisy ip>:8443/admin.jnlp 

But things matched up and worked for me when using:  

    https://isy.universal-devices.com/polisy/5.3.0/admin.jnlp  (though I had to remove the "d" from "universald").

Link to comment
Share on other sites

21 minutes ago, upstatemike said:

So now it gets to the point to ask what ISY on Polisy can do that ISY994 plus Polisy cannot. What is my incentive to move anytime soon when a split system gives me some protection from having a single point of failure?

Lack of devices (connectors, cables, routers, switches, power supplies) between your NSs and ISY programs.

Link to comment
Share on other sites

5 minutes ago, dwengrovitz said:

 

I got the same mismatch between admin console version and firmware as @tazman when using:

     https://<your polisy ip>:8443/admin.jnlp 

But things matched up and worked for me when using:  

    https://isy.universal-devices.com/polisy/5.3.0/admin.jnlp  (though I had to remove the "d" from "universald").

@Michel Kohanim the link downloads the admin console from Polisy and works but using the launcher (https://isy.universal-devices.com/start.jnlp) does not work for local access.

Link to comment
Share on other sites

4 minutes ago, Michel Kohanim said:

Might be a bug. Will review next year.

With kind regards,
Michel

Yes take a well deserved brake! At least we have access and I will try my older Z-Wave locks tomorrow to see how well they work.

Link to comment
Share on other sites

39 minutes ago, Michel Kohanim said:

@tazman,

You must use the ISY Launcher. If not, you need to clear cache and then use either:

https://<your polisy ip>:8443/admin.jnlp or 

https://isy.universald-devices.com/polisy/5.3.0/admin.jnlp 

With kind regards,
Michel

Cleared the Java cache and I'm getting the same error as @tazman when using the ISY launcher. 

When do you think Z-wave migration will be available?

When migrating from the ISY to the Polisy does the ISY still retain its functionality other than the Portal access?

Link to comment
Share on other sites

35 minutes ago, Michel Kohanim said:

@tazman,

Java cache works in mysterious ways. If you ever used the direct link before, the jar file is cached and start.jnlp will use the cache. That's why I mentioned that you need to clear Java cache  if you have use anything but the Launcher before.

With kind regards,
Michel

@Michel Kohanim just a data point I had the same mismatch error when selecting LAN in the Launcher.

However, selecting Cloud in the Launcher and the Admin console launches properly.

Link to comment
Share on other sites

12 minutes ago, Techman said:

Cleared the Java cache and I'm getting the same error as @tazman when using the ISY launcher. 

When do you think Z-wave migration will be available?

When migrating from the ISY to the Polisy does the ISY still retain its functionality other than the Portal access?

@Techman I had the same error when I selected LAN in the Launcher.  I'm not sure if you have a Cloud option but the Launcher worked fine with that option.

Link to comment
Share on other sites

I have a Polisy on its way.

I also ordered an Insteon 2448A7 USB stick (because of no availability of PLM) and have a Zooz z-wave stick. The Insteon stick should work fine based on what others say because as long as I have wireless Insteon devices they will bridge powerline to my older ones. I also have only around 200 Insteon links (the USB stick is half the links around 1000 than the 2000 or so on PLM).

Can't wait to try.

 

 

 

 

 

Link to comment
Share on other sites

30 minutes ago, Michel Kohanim said:

All, it should be fixed. Please click the button on the front once. Clear cache, use the Launcher. 

Z-Wave migration will not happen soon as we have to do S2 and Certification.

With kind regards,
Michel

I can confirm it worked for me now thanks Michel!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.


×
×
  • Create New...